Bug 927320 - Using AS 7.2 / EAP 6.1 client jars to connect to AS 7.0.x fails with hang.
Summary: Using AS 7.2 / EAP 6.1 client jars to connect to AS 7.0.x fails with hang.
Keywords:
Status: CLOSED DUPLICATE of bug 927318
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Remoting
Version: 6.1.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: David M. Lloyd
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-25 16:22 UTC by Rob Stryker
Modified: 2013-04-09 10:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-03-26 09:57:36 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker AS7-6779 0 Blocker Resolved AS7.1 jars run against as7.2/eap6.1 cause test case (eclipse) to hang 2016-02-15 23:02:23 UTC

Description Rob Stryker 2013-03-25 16:22:01 UTC
Description of problem:
Using AS 7.2 / EAP 6.1 client jars to connect to AS 7.0.x fails with hang. 


Version-Release number of selected component (if applicable):
 jboss-as-controller-client-7.2.0.Final-redhat-3.jar,
 jboss-as-logging-7.2.0.Final-redhat-3.jar,
 jboss-as-protocol-7.2.0.Final-redhat-3.jar,
 jboss-dmr-1.1.6.Final-redhat-1.jar,
 jboss-logging-3.1.2.GA-redhat-1.jar,
 jboss-marshalling-1.3.16.GA-redhat-1.jar,
 jboss-marshalling-river-1.3.16.GA-redhat-1.jar,
 jboss-remoting-3.2.15.GA-redhat-1.jar,
 jboss-sasl-1.0.3.Final-redhat-1.jar,
 jboss-threads-2.1.0.Final-redhat-1.jar,
 xnio-api-3.0.7.GA-redhat-1.jar,
 xnio-nio-3.0.7.GA-redhat-1.jar


How reproducible:
Occasionally, if with random management actions. Every time when performed with attached eclipse project. 

Steps to Reproduce:
1. Download and import into eclipse the plain java project attached to https://issues.jboss.org/browse/AS7-6779
2. Set project classpath to use jars from as7.2 folder and Launch an AS 7.0.x server outside of eclipse, OR,  set project classpath to use jars from as7.1 folder and launch an EAP 6.1 outside of eclipse. 
3. Run the new project's main class. 
  
Actual results:
The Main class hangs. In this case the client is a simple Main class. However, when similar code is run as an eclipse plugin, it could freeze the workspace. 

Expected results:
The methods complete without error. 


Additional info:
More information is provided at https://issues.jboss.org/browse/AS7-6779

Comment 2 Rob Stryker 2013-03-26 09:57:36 UTC

*** This bug has been marked as a duplicate of bug 927318 ***

Comment 3 JBoss JIRA Server 2013-03-26 14:43:14 UTC
Emanuel Muckenhuber <emuckenh@redhat.com> made a comment on jira AS7-6779

I assume you are also seeing something like this in the client?

{noformat}
"management-client-thread 1-2" prio=10 tid=0x00007f21a4016000 nid=0x226c in Object.wait() [0x00007f21ffefd000]
   java.lang.Thread.State: WAITING (on object monitor)
	at java.lang.Object.wait(Native Method)
	- waiting on <0x00000007d7386690> (a org.jboss.remoting3.remote.OutboundMessage)
	at java.lang.Object.wait(Object.java:503)
	at org.jboss.remoting3.remote.OutboundMessage$1.accept(OutboundMessage.java:91)
	- locked <0x00000007d7386690> (a org.jboss.remoting3.remote.OutboundMessage)
	at org.xnio.streams.BufferPipeOutputStream.send(BufferPipeOutputStream.java:125)
	at org.xnio.streams.BufferPipeOutputStream.send(BufferPipeOutputStream.java:113)
	at org.xnio.streams.BufferPipeOutputStream.getBuffer(BufferPipeOutputStream.java:77)
	at org.xnio.streams.BufferPipeOutputStream.write(BufferPipeOutputStream.java:95)
	- locked <0x00000007d73866c8> (a org.xnio.streams.BufferPipeOutputStream)
	at org.jboss.remoting3.remote.OutboundMessage.write(OutboundMessage.java:176)
	at java.io.DataOutputStream.write(DataOutputStream.java:107)
	- locked <0x00000007d7388760> (a java.io.DataOutputStream)
	at java.io.FilterOutputStream.write(FilterOutputStream.java:97)
	at org.jboss.as.protocol.mgmt.FlushableDataOutputImpl.write(FlushableDataOutputImpl.java:118)
	at org.jboss.as.controller.client.impl.AbstractModelControllerClient$ReadAttachmentInputStreamRequestHandler$1.execute(AbstractModelControllerClient.java:208)
	at org.jboss.as.protocol.mgmt.AbstractMessageHandler$2$1.doExecute(AbstractMessageHandler.java:287)
	at org.jboss.as.protocol.mgmt.AbstractMessageHandler$AsyncTaskRunner.run(AbstractMessageHandler.java:483)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:722)
	at org.jboss.threads.JBossThread.run(JBossThread.java:122)
{noformat}

Comment 4 JBoss JIRA Server 2013-03-27 17:48:00 UTC
Rob Stryker <rob.stryker@jboss.com> made a comment on jira AS7-6779

Attaching a jstack of the process.  I am not seeing what you are expecting. 

This stack is what I see when using 7.1 jars against eap6.1.

Comment 5 JBoss JIRA Server 2013-04-08 19:35:06 UTC
Emanuel Muckenhuber <emuckenh@redhat.com> updated the status of jira AS7-6779 to Resolved

Comment 6 JBoss JIRA Server 2013-04-08 19:35:06 UTC
Emanuel Muckenhuber <emuckenh@redhat.com> made a comment on jira AS7-6779

using jboss-remoting-3.2.16.GA will resolve the issue.

Comment 7 JBoss JIRA Server 2013-04-08 21:22:58 UTC
Rob Stryker <rob.stryker@jboss.com> made a comment on jira AS7-6779

Where would I download specific versions of jboss-remoting? The last version on the remoting page is 3.1.0.Beta2 which was added in 2010.  http://www.jboss.org/jbossremoting/downloads

Comment 8 JBoss JIRA Server 2013-04-08 21:26:47 UTC
Emanuel Muckenhuber <emuckenh@redhat.com> made a comment on jira AS7-6779

Aha, well i'd just take the artifact from maven then: https://repository.jboss.org/nexus/content/groups/public/org/jboss/remoting3/jboss-remoting/3.2.16.GA/

Comment 9 JBoss JIRA Server 2013-04-09 10:40:14 UTC
Max Rydahl Andersen <max.andersen@redhat.com> made a comment on jira AS7-6779

Emanuel, what does the fix entail ? 

Which servers can we expect to continue to use this remoting client with ?

All AS 7.1.x/7.2.x + EAP 6.0.x/6.1.x and upwards ? 

If yes we will just use the old ones for AS 7.0 and use these new ones for future updates.


Note You need to log in before you can comment on or make changes to this bug.