Bug 927378 - rubygem-glib2 1.2.3 breaks alexandria
Summary: rubygem-glib2 1.2.3 breaks alexandria
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rubygem-glib2
Version: 18
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Mamoru TASAKA
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 927471
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-25 19:35 UTC by James Begley
Modified: 2013-04-05 23:05 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-04-05 22:57:03 UTC


Attachments (Terms of Use)

Description James Begley 2013-03-25 19:35:52 UTC
Description of problem:
A recent update has broken alexandria to the point where it won't run. Looking at the errors, my guess is rubygem-glib2 but I'm no ruby expert, so I might be wrong :)

Version-Release number of selected component (if applicable):
rubygem-glib2-1.2.3-1.fc18.x86_64
alexandria-0.6.9-2.fc18.noarch

How reproducible:
Always

Steps to Reproduce:
1. run alexandria
2.
3.
  
Actual results:
alexandria 
/usr/share/rubygems/rubygems/custom_require.rb:36:in `require': cannot load such file -- glib2.so (LoadError)
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/gems/gems/glib2-1.2.3/lib/glib2.rb:100:in `rescue in <top (required)>'
	from /usr/share/gems/gems/glib2-1.2.3/lib/glib2.rb:96:in `<top (required)>'
	from /usr/share/rubygems/rubygems/custom_require.rb:60:in `require'
	from /usr/share/rubygems/rubygems/custom_require.rb:60:in `rescue in require'
	from /usr/share/rubygems/rubygems/custom_require.rb:35:in `require'
	from /usr/share/ruby/vendor_ruby/alexandria/utils.rb:18:in `<top (required)>'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/ruby/vendor_ruby/alexandria.rb:58:in `<top (required)>'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/bin/alexandria:15:in `<main>'

Expected results:
Alexandria should run

Additional info:

Comment 1 Mamoru TASAKA 2013-03-26 02:20:15 UTC
Ahhh, actually my mistake, sorry.

Comment 2 Fedora Update System 2013-03-26 05:57:55 UTC
rubygem-atk-1.2.4-1.fc17, rubygem-gdk_pixbuf2-1.2.4-1.fc17, rubygem-gio2-1.2.4-1.fc17, rubygem-glib2-1.2.4-1.fc17, rubygem-gobject-introspection-1.2.4-1.fc17, rubygem-goocanvas-1.2.4-1.fc17, rubygem-gstreamer-1.2.4-1.fc17, rubygem-gtk2-1.2.4-1.fc17, rubygem-gtksourceview2-1.2.4-1.fc17, rubygem-pango-1.2.4-1.fc17, rubygem-poppler-1.2.4-1.fc17, rubygem-rsvg2-1.2.4-1.fc17, rubygem-vte-1.2.4-1.fc17, rubygem-cairo-1.12.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2013-4172/rubygem-cairo-1.12.4-1.fc17,rubygem-atk-1.2.4-1.fc17,rubygem-gdk_pixbuf2-1.2.4-1.fc17,rubygem-gio2-1.2.4-1.fc17,rubygem-glib2-1.2.4-1.fc17,rubygem-gobject-introspection-1.2.4-1.fc17,rubygem-goocanvas-1.2.4-1.fc17,rubygem-gstreamer-1.2.4-1.fc17,rubygem-gtk2-1.2.4-1.fc17,rubygem-gtksourceview2-1.2.4-1.fc17,rubygem-pango-1.2.4-1.fc17,rubygem-poppler-1.2.4-1.fc17,rubygem-rsvg2-1.2.4-1.fc17,rubygem-vte-1.2.4-1.fc17

Comment 3 Fedora Update System 2013-03-26 06:09:52 UTC
rubygem-cairo-1.12.4-1.fc18, rubygem-atk-1.2.4-1.fc18, rubygem-gdk_pixbuf2-1.2.4-1.fc18, rubygem-gio2-1.2.4-1.fc18, rubygem-glib2-1.2.4-1.fc18, rubygem-gobject-introspection-1.2.4-1.fc18, rubygem-goocanvas-1.2.4-1.fc18, rubygem-gstreamer-1.2.4-1.fc18, rubygem-gtk2-1.2.4-1.fc18, rubygem-gtksourceview2-1.2.4-1.fc18, rubygem-pango-1.2.4-1.fc18, rubygem-poppler-1.2.4-1.fc18, rubygem-rsvg2-1.2.4-1.fc18, rubygem-vte-1.2.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-4156/rubygem-cairo-1.12.4-1.fc18,rubygem-atk-1.2.4-1.fc18,rubygem-gdk_pixbuf2-1.2.4-1.fc18,rubygem-gio2-1.2.4-1.fc18,rubygem-glib2-1.2.4-1.fc18,rubygem-gobject-introspection-1.2.4-1.fc18,rubygem-goocanvas-1.2.4-1.fc18,rubygem-gstreamer-1.2.4-1.fc18,rubygem-gtk2-1.2.4-1.fc18,rubygem-gtksourceview2-1.2.4-1.fc18,rubygem-pango-1.2.4-1.fc18,rubygem-poppler-1.2.4-1.fc18,rubygem-rsvg2-1.2.4-1.fc18,rubygem-vte-1.2.4-1.fc18

Comment 4 James Begley 2013-03-26 21:32:24 UTC
I've updated to the versions linked to in comment #3, and now get a bit further:

alexandria 
/usr/share/rubygems/rubygems/custom_require.rb:36:in `require': iconv will be deprecated in the future, use String#encode instead.
/usr/share/rubygems/rubygems/custom_require.rb:60:in `require': /usr/lib64/gems/exts/pango-1.2.4/lib/pango.so: undefined symbol: rb_cCairo_Context - /usr/lib64/gems/exts/pango-1.2.4/lib/pango.so (LoadError)
	from /usr/share/rubygems/rubygems/custom_require.rb:60:in `rescue in require'
	from /usr/share/rubygems/rubygems/custom_require.rb:35:in `require'
	from /usr/share/gems/gems/pango-1.2.4/lib/pango.rb:28:in `rescue in <top (required)>'
	from /usr/share/gems/gems/pango-1.2.4/lib/pango.rb:24:in `<top (required)>'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/gems/gems/gtk2-1.2.4/lib/gtk2/base.rb:13:in `<top (required)>'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/gems/gems/gtk2-1.2.4/lib/gtk2.rb:10:in `<top (required)>'
	from /usr/share/rubygems/rubygems/custom_require.rb:60:in `require'
	from /usr/share/rubygems/rubygems/custom_require.rb:60:in `rescue in require'
	from /usr/share/rubygems/rubygems/custom_require.rb:35:in `require'
	from /usr/share/ruby/vendor_ruby/alexandria/ui/gtk_thread_help.rb:35:in `<top (required)>'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/ruby/vendor_ruby/alexandria/ui.rb:20:in `<top (required)>'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/ruby/vendor_ruby/alexandria.rb:75:in `<top (required)>'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /usr/bin/alexandria:15:in `<main>'

Comment 5 Mamoru TASAKA 2013-03-27 04:15:52 UTC
rubygem-cairo updated, sorry again.

Comment 6 Mamoru TASAKA 2013-03-28 03:41:21 UTC
This time alexandria should work.

Comment 7 James Begley 2013-03-28 18:41:51 UTC
With the updated version of rubygem-cairo I can confirm that alexandria is now working again.  Thanks.

Comment 8 Mamoru TASAKA 2013-03-29 00:19:50 UTC
Thank you for confirming.

Comment 9 Fedora Update System 2013-04-05 22:57:05 UTC
rubygem-atk-1.2.4-1.fc18, rubygem-gdk_pixbuf2-1.2.4-1.fc18, rubygem-gio2-1.2.4-1.fc18, rubygem-glib2-1.2.4-1.fc18, rubygem-gobject-introspection-1.2.4-1.fc18, rubygem-goocanvas-1.2.4-1.fc18, rubygem-gstreamer-1.2.4-1.fc18, rubygem-gtk2-1.2.4-1.fc18, rubygem-gtksourceview2-1.2.4-1.fc18, rubygem-pango-1.2.4-1.fc18, rubygem-poppler-1.2.4-1.fc18, rubygem-rsvg2-1.2.4-1.fc18, rubygem-vte-1.2.4-1.fc18, rubygem-cairo-1.12.4-1.fc18.1 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2013-04-05 23:05:13 UTC
rubygem-atk-1.2.4-1.fc17, rubygem-gdk_pixbuf2-1.2.4-1.fc17, rubygem-gio2-1.2.4-1.fc17, rubygem-glib2-1.2.4-1.fc17, rubygem-gobject-introspection-1.2.4-1.fc17, rubygem-goocanvas-1.2.4-1.fc17, rubygem-gstreamer-1.2.4-1.fc17, rubygem-gtk2-1.2.4-1.fc17, rubygem-gtksourceview2-1.2.4-1.fc17, rubygem-pango-1.2.4-1.fc17, rubygem-poppler-1.2.4-1.fc17, rubygem-rsvg2-1.2.4-1.fc17, rubygem-vte-1.2.4-1.fc17, rubygem-cairo-1.12.4-1.fc17.1 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.