Bug 927443 - iaxclient not building correctly on ARM platform
iaxclient not building correctly on ARM platform
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: iaxclient (Show other bugs)
19
arm Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
: 868489 (view as bug list)
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2013-03-25 18:25 EDT by Jared Smith
Modified: 2013-07-25 20:37 EDT (History)
3 users (show)

See Also:
Fixed In Version: iaxclient-2.1-0.13.beta3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 22:12:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jared Smith 2013-03-25 18:25:56 EDT
Description of problem:

iaxclient is not building correctly on ARM

Version-Release number of selected component (if applicable):

iaxclient-2.1-0.12.beta3.fc19

How reproducible:

Always

Steps to Reproduce:
1. Try to do a scratch build in ARM Koji
2. Notice that the build fails

  
Actual results:

ringbuffer.c:124:11: error: #error Memory barriers are not defined on this system. You can still compile by defining ALLOW_SMP_DANGERS, but SMP safety will not be guaranteed.

Expected results:

I was hoping that iaxclient would build.

Additional info:
Comment 1 Paul Jenner 2013-07-14 07:02:12 EDT
Duplicate of #868489 ?
Comment 2 Tom "spot" Callaway 2013-07-15 22:10:08 EDT
*** Bug 868489 has been marked as a duplicate of this bug. ***
Comment 3 Tom "spot" Callaway 2013-07-15 22:11:57 EDT
I've checked a fix for this into the f19 and rawhide branch, but I've only rebuilt in rawhide. If you need this in f19, just kick off an arm build.
Comment 4 Peter Robinson 2013-07-16 06:56:16 EDT
(In reply to Tom "spot" Callaway from comment #3)
> I've checked a fix for this into the f19 and rawhide branch, but I've only
> rebuilt in rawhide. If you need this in f19, just kick off an arm build.

As a note we only build what is built and tagged on mainline.
Comment 5 Tom "spot" Callaway 2013-07-16 09:39:14 EDT
Okay, well, I don't mind pushing this as an update for x86*, but it really only fixes anything on ARM.
Comment 6 Peter Robinson 2013-07-16 09:50:50 EDT
(In reply to Tom "spot" Callaway from comment #5)
> Okay, well, I don't mind pushing this as an update for x86*, but it really
> only fixes anything on ARM.

Yes, I understand but it's standard policy for secondary arches that all fixes need to be pushed to mainline. It would be great if you could, else I don't mind doing it.
Comment 7 Fedora Update System 2013-07-16 09:53:15 EDT
iaxclient-2.1-0.13.beta3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/iaxclient-2.1-0.13.beta3.fc19
Comment 8 Fedora Update System 2013-07-25 20:37:15 EDT
iaxclient-2.1-0.13.beta3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.