Bug 928104 - telnet-server will not accept connections from Linux telnet client
Summary: telnet-server will not accept connections from Linux telnet client
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux
Version: 18
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-26 22:22 UTC by David Walser
Modified: 2014-02-05 23:06 UTC (History)
4 users (show)

Fixed In Version: util-linux-2.22.2-7.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-05 23:06:54 UTC
Type: Bug


Attachments (Terms of Use)
strace log when connecting from a Linux machine (10.49 KB, application/octet-stream)
2013-03-26 22:22 UTC, David Walser
no flags Details
strace log when connecting from a Windows machine (21.13 KB, text/plain)
2013-03-26 22:22 UTC, David Walser
no flags Details

Description David Walser 2013-03-26 22:22:06 UTC
Created attachment 716755 [details]
strace log when connecting from a Linux machine

If you have telnet-server installed and enabled through xinetd, if you try to telnet to the Fedora 18 machine from another Linux machine, it immediately closes the connection after printing the /etc/issue.net file:
Fedora release 18 (Spherical Cow)
Kernel 3.7.2-201.fc18.i686.PAE on an i686 (3)
Connection closed by foreign host.

If you look in /var/log/secure on the Fedora 18 machine, you see:
Mar 26 17:04:36 C-STU11-Fedora login: FATAL: can't reopen tty: No such file or directory

If you telnet from a Windows machine, it works.

I changed in /etc/xinetd.d/telnet the server part to:
server = /bin/strace
server_args = -o /var/tmp/telnet.trace /usr/sbin/in.telnetd

and collected strace logs from connecting from Linux and Windows.  I'll attach these.

Comment 1 David Walser 2013-03-26 22:22:38 UTC
Created attachment 716756 [details]
strace log when connecting from a Windows machine

Comment 2 Fedora Admin XMLRPC Client 2013-04-02 13:26:18 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Michal Sekletar 2013-07-30 17:30:06 UTC
Is this still an issue? I think it should be fixed now.

Comment 4 David Walser 2013-07-31 13:17:59 UTC
Nothing has happened with this package since I reported this bug, no updates have been issued  (for Fedora 18), so yes this is still broken.

We fixed it in our own systems by removing this package and installing krb5-appl-servers instead.

I tried it on Fedora 19 and it works fine both as a systemd service or xinetd service, and nothing has changed in the code.  The compiler flags have changed.  Maybe the package in Fedora 18 was just broken by the compiler somehow.

Comment 5 Michal Sekletar 2013-07-31 16:00:16 UTC
I should have mentioned that this bug is actually caused by /usr/bin/login from util-linux package. Issue should be fixed in util-linux - 2.23.1-2. util-linux update should land in f18-updates-testing soon.

Comment 6 Fedora Update System 2013-08-01 12:35:20 UTC
util-linux-2.22.2-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/util-linux-2.22.2-7.fc18

Comment 7 Fedora Update System 2013-08-02 22:06:33 UTC
Package util-linux-2.22.2-7.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing util-linux-2.22.2-7.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14142/util-linux-2.22.2-7.fc18
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2013-09-08 00:34:02 UTC
util-linux-2.22.2-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 David Walser 2013-09-08 00:42:21 UTC
Why was this update pushed?  Does anyone read the QA reports on the admin.fedoraproject.org site?  This is still very broken.

Comment 10 Fedora End Of Life 2013-12-21 15:27:07 UTC
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 11 Fedora End Of Life 2014-02-05 23:06:54 UTC
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.