Bug 928269 - Warning: 'serial' is deprecated and has been removed.
Summary: Warning: 'serial' is deprecated and has been removed.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: ---
Assignee: Will Woods
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-27 09:49 UTC by Jan Stancek
Modified: 2014-06-18 01:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 11:44:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Stancek 2013-03-27 09:49:23 UTC
Description of problem:
I'm getting following warning about 'serial' option:
dracut-cmdline[67]: Warning: 'serial' is deprecated and has been removed. 
dracut-cmdline[67]: Warning: To change the console use 'console=' instead. 

which according to https://fedoraproject.org/wiki/Anaconda_Boot_Options is the only way to "Carry over console settings to the installed system"

Version-Release number of selected component (if applicable):
anaconda-18.37.11-13.el7

How reproducible:
100%

Steps to Reproduce:
1. start installation with 'serial'
  
Actual results:
warning

Expected results:
no warning, 'serial' option supported

Additional info:

Comment 2 Chris Lumens 2013-03-27 13:15:53 UTC
The documentation needs to be updated, not the serial option.

Comment 3 Jan Stancek 2013-03-27 13:47:55 UTC
(In reply to comment #2)
> The documentation needs to be updated, not the serial option.

Is there a replacement for serial? For example, we currently have "console=ttyS0,115200 serial" on command line and serial console works during installation and also after first boot (including grub).

Comment 4 Bill Nottingham 2013-03-27 21:09:17 UTC
Just remove 'serial' and you should be fine...

Comment 5 Jan Stancek 2013-03-27 21:49:15 UTC
(In reply to comment #4)
> Just remove 'serial' and you should be fine...

Without 'serial', serial console doesn't work after reboot:

# cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-3.8.0-0.40.el7.x86_64 root=/dev/mapper/rhel_intel--waimeabay--hedt--01-root ro rd.md=0 rd.dm=0 crashkernel=auto rd.luks=0 rd.lvm.lv=rhel_intel-waimeabay-hedt-01/swap vconsole.keymap=us rd.lvm.lv=rhel_intel-waimeabay-hedt-01/root rhgb quiet

# cat /etc/default/grub
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.md=0 rd.dm=0 $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rd.luks=0 rd.lvm.lv=rhel_intel-waimeabay-hedt-01/swap vconsole.keymap=us rd.lvm.lv=rhel_intel-waimeabay-hedt-01/root rhgb quiet"
GRUB_DISABLE_RECOVERY="true"
GRUB_THEME="/boot/grub2/themes/system/theme.txt"

Comment 6 Will Woods 2013-04-11 17:38:37 UTC
(In reply to comment #5)
> Without 'serial', serial console doesn't work after reboot

Confirmed in testing here. Should be fixed in this commit:

  https://git.fedorahosted.org/cgit/anaconda.git/commit/?id=0b64177

From the commit message, here's the intended behavior:

  * "serial" is deprecated and ignored; try "console=ttyS0" instead.
  * If you use "console=XXX" it will be preserved in the installed system.
  * If multiple "console=XXX" args are used, the *last* one is preserved.

Comment 8 Michal Kovarik 2014-02-04 09:40:01 UTC
Verified on anaconda-19.31.50-1, serial option is ignored. "console" is preserved in the installed system.

Comment 9 Ludek Smid 2014-06-13 11:44:57 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.