Bug 928339 - systemd[1]: Failed to mount /run: No such file or directory
systemd[1]: Failed to mount /run: No such file or directory
Status: CLOSED DUPLICATE of bug 922988
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 928338 928994 (view as bug list)
Depends On:
Blocks: F19Alpha/F19AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-03-27 09:23 EDT by Kamil Páral
Modified: 2013-04-03 21:58 EDT (History)
21 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-02 12:07:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
boot messages (9.04 KB, image/png)
2013-03-27 09:23 EDT, Kamil Páral
no flags Details
verbose boot messages (20.17 KB, image/png)
2013-03-27 09:25 EDT, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2013-03-27 09:23:47 EDT
Created attachment 717074 [details]
boot messages

Description of problem:
I installed F19 from F19 Alpha TC2 Live x86_64. After reboot, I see this error message:

> systemd[1]: Failed to mount /run: No such file or directory

And I have to hard-reboot the computer, nothing else works. selinux=0 doesn't help.

Version-Release number of selected component (if applicable):
F19 Alpha TC2
Comment 1 Kamil Páral 2013-03-27 09:25:46 EDT
Created attachment 717076 [details]
verbose boot messages
Comment 2 Kamil Páral 2013-03-27 09:30:49 EDT
Proposing as an Alpha blocker:
All release-blocking images must boot in their supported configurations.
http://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria
Comment 3 Harald Hoyer 2013-03-27 10:00:40 EDT
Can you boot with "rd.break" on the kernel command line and check, that /sysroot/run is present?

If no, please reassign the bug to anaconda.
Comment 4 Kamil Páral 2013-03-27 12:07:15 EDT
/sysroot is present, /sysroot/run is not. Reassigning to anaconda.
Comment 5 Adam Williamson 2013-03-27 14:02:43 EDT
Discussed at 2013-03-27 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-03-27/f19alpha-blocker-review-3.2013-03-27-16.01.log.txt . Accepted as a blocker per criterion "A system installed with a graphical package set must boot to the 'firstboot' utility on the first boot after installation. The firstboot utility must be able to create a working user account." (the criterion cited in comment #2 does not apply). This appears to be different from #922988, as it didn't affect TC1.
Comment 6 Michal Schmidt 2013-03-27 16:43:00 EDT
*** Bug 928338 has been marked as a duplicate of this bug. ***
Comment 7 Chris Lumens 2013-03-28 10:12:31 EDT
Why was this reassigned to anaconda?  We don't construct the initrd.  We only call other programs to do that for us.
Comment 8 Kamil Páral 2013-03-28 10:24:47 EDT
Changing needinfo to Harald for a closer explanation.
Comment 9 Stef Walter 2013-03-28 10:58:43 EDT
Can reproduce this here as well.
Comment 10 Adam Williamson 2013-03-28 16:03:31 EDT
clumens: I think on the basis that it's similar to / the same as:

https://bugzilla.redhat.com/show_bug.cgi?id=922988

particularly:

https://bugzilla.redhat.com/show_bug.cgi?id=922988#c16

i.e. there's no sysroot/run during install. But I don't know if we're missing something there.
Comment 11 Jens Petersen 2013-03-29 05:30:49 EDT
Is it only happening for Live installs?
Comment 12 Kamil Páral 2013-03-29 06:23:00 EDT
Yes, I see this particular problem just on Live install.

However, I just tried F19 Alpha TC3 Live x86_64 and the installed system booted correctly. I didn't even disable selinux. The problem seems to be fixed.
Comment 13 Harald Hoyer 2013-04-02 03:34:35 EDT
I think this is a duplicate of bug 922988
Comment 14 Jens Petersen 2013-04-02 04:05:52 EDT
Changing to MODIFIED then based on comment 12,
but feel free to mark it a duplicate or close as appropriate.
Comment 15 Adam Williamson 2013-04-02 12:07:28 EDT
harald: good enough for me.

*** This bug has been marked as a duplicate of bug 922988 ***
Comment 16 Jens Petersen 2013-04-03 21:58:13 EDT
*** Bug 928994 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.