Bug 928643 - gdm running in C locale for non-Live installs (was: gnome-initial-setup shows question marks when selecting an input source)
Summary: gdm running in C locale for non-Live installs (was: gnome-initial-setup shows...
Keywords:
Status: CLOSED DUPLICATE of bug 949525
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 949970 (view as bug list)
Depends On:
Blocks: F19Alpha-accepted, F19AlphaFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-03-28 06:42 UTC by Mike FABIAN
Modified: 2013-04-11 04:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-08 11:59:21 UTC


Attachments (Terms of Use)
gnome-initial-setup-input-sources-question-marks-when-selecting-input-source.png (704.85 KB, image/png)
2013-03-28 06:42 UTC, Mike FABIAN
no flags Details

Description Mike FABIAN 2013-03-28 06:42:03 UTC
Created attachment 717456 [details]
gnome-initial-setup-input-sources-question-marks-when-selecting-input-source.png

- Install Fedora-19-Alpha-TC2-x86_64-DVD.iso in qemu.

  Commandline used for qemu was:

ionice -c 3 qemu-kvm -enable-kvm -m 2048M -smp 1 -drive file=./Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2,index=0,media=disk,cache=unsafe -localtime -serial file:/tmp/qemu-Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2-output.log -name Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2 -cdrom /local/mfabian/iso/Fedora-19-Alpha-TC2/Fedora-19-Alpha-TC2-x86_64-DVD.iso -boot c -vga std -display vnc=:4 -net nic -net user,hostname=Fedora-19-Alpha-TC2-x86_64-DVD.iso.qcow2,hostfwd=tcp::5560-:22 -monitor stdio -usb

- Select Japanese
- Select to install on whole disk
- Select Timezone
- Select default Gnome install
- continue with installation

after the first reboot, gnome-initial-setup shows up

After selecting the language there, on can add input sources.

The list of input sources is initially empty, I think
there should be a keyboard and a Japanese input method already
by default.

When trying to add an input source, all non-ASCII stuff in the names
of the input sources is displayed as question marks.
Makes it hard to select an input source.

See attached screen shot.

Comment 1 Jens Petersen 2013-03-28 07:40:11 UTC
Similarly if I chose German in gnome-initial-setup I see
question marks instead of German umlauts in gnome-initial-setup's
list of input sources.

It looks like some kind of text encoding corruption anyway.

Comment 2 Mike FABIAN 2013-03-28 07:50:05 UTC
I guess this is because the process is running in “C” locale:

[root@Fedora-19-Alpha-TC2-x86_64-DVD ~]# ps aux | grep initial
gnome-i+   747  0.0  0.6 640376 13104 ?        Ssl  08:41   0:00 /usr/bin/gnome-session --autostart /usr/share/gdm/greeter/autostart --session gnome-initial-setup
gnome-i+   750  0.0  0.0  13916   732 ?        S    08:41   0:00 /usr/bin/dbus-launch --exit-with-session /usr/bin/gnome-session --autostart /usr/share/gdm/greeter/autostart --session gnome-initial-setup
gnome-i+   861  1.3  8.9 1292724 182120 ?      Sl   08:41   0:03 gnome-shell --mode=initial-setup
gnome-i+   862  0.7  2.7 871896 56668 ?        Sl   08:41   0:01 /usr/libexec/gnome-initial-setup
root      1833  0.0  0.0 112652   980 pts/0    S+   08:46   0:00 grep --color=auto initial
[root@Fedora-19-Alpha-TC2-x86_64-DVD ~]# cat /proc/747/environ | xargs -0 -n 1 echo | grep LANG
GDM_LANG=C
LANG=C
[root@Fedora-19-Alpha-TC2-x86_64-DVD ~]# cat /proc/750/environ | xargs -0 -n 1 echo | grep LANG
GDM_LANG=C
LANG=C
[root@Fedora-19-Alpha-TC2-x86_64-DVD ~]# cat /proc/861/environ | xargs -0 -n 1 echo | grep LANG
GDM_LANG=C
LANG=C
[root@Fedora-19-Alpha-TC2-x86_64-DVD ~]# cat /proc/862/environ | xargs -0 -n 1 echo | grep LANG
GDM_LANG=C
LANG=C
[root@Fedora-19-Alpha-TC2-x86_64-DVD ~]#

Comment 3 Mike FABIAN 2013-03-30 16:34:11 UTC
Problem is still there on Fedora-19-Alpha-TC3-x86_64-DVD.iso

Comment 4 Mike FABIAN 2013-04-04 06:28:43 UTC
Problem is still there on edora-19-Alpha-TC4-x86_64-netinst.iso

Comment 5 Jens Petersen 2013-04-05 04:52:47 UTC
I did a TC4 Live install with anaconda-19.16 and did not see any question marks I think today.

Comment 6 Mike FABIAN 2013-04-05 08:23:01 UTC
Strange,  I still see the question marks, I wonder how anaconda
could influence that.

Comment 7 Jens Petersen 2013-04-08 07:37:59 UTC
Well it might be Live vs non-Live.

I also see question marks again today after TC5 net install.

Comment 8 Jens Petersen 2013-04-08 08:22:27 UTC
(In reply to comment #7)
> Well it might be Live vs non-Live.

Yes I tried Live TC5 and do not see any question marks.
So seems after Live install gnome-initial-setup runs in utf8
but not for non-Live installs.
(coincidently vconsole also seems to be in unicode mode).

Comment 9 Jens Petersen 2013-04-08 11:59:21 UTC

*** This bug has been marked as a duplicate of bug 949525 ***

Comment 10 Jens Petersen 2013-04-11 04:15:38 UTC
*** Bug 949970 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.