Bug 928704 - gnome-terminal crashes when new profile (or profile edit) is requested
Summary: gnome-terminal crashes when new profile (or profile edit) is requested
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-terminal
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 928319 (view as bug list)
Depends On:
Blocks: F19Alpha-accepted, F19AlphaFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-03-28 09:28 UTC by Filip Holec
Modified: 2016-04-18 10:22 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-09 03:38:11 UTC


Attachments (Terms of Use)

Description Filip Holec 2013-03-28 09:28:32 UTC
Description of problem:
When trying to create new profile, gnome-terminal crashes (probably due to segfault in libgio-2.0.so.0.3600.0 (error 4), but new profile 'Unnamed' is created). Editing profiles also results in terminal crash.

Version-Release number of selected component (if applicable):
gnome-terminal-3.8.0-1.fc19.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open gnome-terminal
2. File -> New Profile
3. (or) Edit -> Profile Preferences
  
Actual results:
gnome-terminal crash

Expected results:
Standard new profile window
(or) standard profile preferences window

Additional info:

Comment 1 sangu 2013-03-30 02:28:50 UTC
I can reproduce this.

$ gdb /usr/libexec/gnome-terminal-server coredump

Core was generated by `/usr/libexec/gnome-terminal-server'.
Program terminated with signal 11, Segmentation fault.

#0  _gdk_device_xi2_reset_scroll_valuators (device=device@entry=0x0)
    at gdkdevice-xi2.c:853
853	  for (i = 0; i < device->scroll_valuators->len; i++)

(gdb) bt
#0  _gdk_device_xi2_reset_scroll_valuators (device=device@entry=0x0)
    at gdkdevice-xi2.c:853
#1  0x00007f067a848ac9 in gdk_x11_device_manager_xi2_translate_event (
    translator=<optimized out>, display=0x2319020 [GdkX11Display], 
    event=0x243fd60, xevent=0x7fff1de96ad0) at gdkdevicemanager-xi2.c:1558
#2  0x00007f067a852ec2 in _gdk_x11_event_translator_translate (
    translator=translator@entry=0x22e4e80, display=0x2319020 [GdkX11Display], 
    xevent=xevent@entry=0x7fff1de96ad0) at gdkeventtranslator.c:51
#3  0x00007f067a852991 in gdk_event_source_translate_event (
    xevent=0x7fff1de96ad0, event_source=0x232a9c0) at gdkeventsource.c:227
#4  _gdk_x11_display_queue_events (display=0x2319020 [GdkX11Display])
    at gdkeventsource.c:338
#5  0x00007f067a8278a8 in gdk_display_get_event (
    display=display@entry=0x2319020 [GdkX11Display]) at gdkdisplay.c:313
#6  0x00007f067a852662 in gdk_event_source_dispatch (
    source=source@entry=0x232a9c0, callback=<optimized out>, 
    user_data=<optimized out>) at gdkeventsource.c:360
#7  0x00007f0678fa7f46 in g_main_dispatch (context=0x230c730) at gmain.c:3054
#8  g_main_context_dispatch (context=context@entry=0x230c730) at gmain.c:3630
#9  0x00007f0678fa8298 in g_main_context_iterate (
    context=context@entry=0x230c730, block=block@entry=1, 
    dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3701
#10 0x00007f0678fa833c in g_main_context_iteration (context=0x230c730, 
---Type <return> to continue, or q <return> to quit---
    context@entry=0x0, may_block=may_block@entry=1) at gmain.c:3762
#11 0x00007f0679571564 in g_application_run (
    application=application@entry=0x2322390 [TerminalApp], argc=argc@entry=0, 
    argv=argv@entry=0x0) at gapplication.c:1623
#12 0x0000000000411440 in main (argc=1, argv=0x7fff1de96e98) at server.c:125

And, this trace equate to trace in https://bugzilla.gnome.org/show_bug.cgi?id=693941

Comment 2 sangu 2013-03-31 11:46:50 UTC
See Also : https://bugzilla.gnome.org/show_bug.cgi?id=696921 terminal crashes when opening the profile editor

Comment 3 sangu 2013-03-31 12:56:55 UTC
Duplicated bug 928319 ?

Comment 4 sangu 2013-03-31 16:23:33 UTC
Ignore comment #1 

When testing now, backtrace equates to bug 92819

Comment 5 Piruthiviraj Natarajan 2013-03-31 17:08:44 UTC
I have this issue too
 dmesg output shows 
 gnome-terminal-[4205]: segfault at 0 ip 00007fabfef303d0 sp 00007fff06ed8290 error 4 in libgio-2.0.so.0.3600.0[7fabfee87000+152000]

Comment 6 Fedora Update System 2013-04-02 21:06:04 UTC
gnome-terminal-3.8.0.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-terminal-3.8.0.1-1.fc19

Comment 7 Kalev Lember 2013-04-02 21:06:41 UTC
*** Bug 928319 has been marked as a duplicate of this bug. ***

Comment 8 Kalev Lember 2013-04-02 21:27:02 UTC
Proposing as a F19 Alpha Freeze Exception. Would be nice to have a gnome-terminal without crashing preferences on the live media.

Comment 9 Fedora Update System 2013-04-03 16:11:38 UTC
Package gnome-terminal-3.8.0.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-terminal-3.8.0.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4762/gnome-terminal-3.8.0.1-1.fc19
then log in and leave karma (feedback).

Comment 10 Adam Williamson 2013-04-03 18:25:55 UTC
Discussed at 2013-04-03 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-04-03/f19alpha-blocker-review-4.2013-04-03-16.01.log.txt . Accepted as a freeze exception - this would be an annoying bug for anyone who wanted to configure their terminal in a live session, and it's early in freeze right now. We'll try and land it quickly, please try and get karma on the update.

Comment 11 Fedora Update System 2013-04-09 03:38:18 UTC
gnome-terminal-3.8.0.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.