Bug 928747 - if sum of all LVs is less than remaining disk free, anaconda makes a PV that is only big enough for all LVs
Summary: if sum of all LVs is less than remaining disk free, anaconda makes a PV that ...
Keywords:
Status: CLOSED DUPLICATE of bug 917880
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Lehman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-28 11:29 UTC by Patrick C. F. Ernzer
Modified: 2013-04-10 20:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-10 20:01:45 UTC
Type: Bug


Attachments (Terms of Use)

Description Patrick C. F. Ernzer 2013-03-28 11:29:10 UTC
Description of problem:
unexpected behaviour from anaconda.

I generally have my disks set up like such
- small boot
- PV of rest of disk, luks crypted if the computer is a laptop
- LVs sized to my needs
- lots of free PEs so that I can grow my LVs as needed and create new ones

Version-Release number of selected component (if applicable):
Fedora 18

How reproducible:
did not try

Steps to Reproduce:
1. boot into F18's anaconda (this was done with a new machine, meaning empty disk)
2. manual partition
3. check the encrypt button
4. select auto-fill
5. adjust sizes of / and /home downwards
6. add new LVs if you wish (I did)
7. make sure the sum of your LVs + boot is less than your disk size
  
Actual results:
anaconda created a PV on a luks device, so far so good, but the PV and the underlying luks device were sized so that I have no free space in the VG to speak of (1 PE free to be exact)

# vgdisplay 
  --- Volume group ---
  VG Name               fedora_x230
  System ID             
  Format                lvm2
  Metadata Areas        1
  Metadata Sequence No  6
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                5
  Open LV               5
  Max PV                0
  Cur PV                1
  Act PV                1
  VG Size               163,55 GiB
  PE Size               4,00 MiB
  Total PE              41870
  Alloc PE / Size       41869 / 163,55 GiB
  Free  PE / Size       1 / 4,00 MiB
  VG UUID               blahblahblah

Expected results:
one of the main reasons why I use LVM is the flexibility I have with lvcreate and lvresize.
Obviously, for this to work, I expect anaconda to either ask me if I want my LV smaller than remaining disk free or just use all free space

VG Size               230 Gib (the size of my disk minus /boot)
Free  PE              lots of them


Additional info:
- it could be that while this behaviour is unexpected to me and certainly not useful to me, this was actually intended (Bug 917880 comment #2 although that bug is about install from Live boot). If it is working as intended, then just close this bug.
- this bug has no urgency for me, I'll adjust my luks volume and PV manually, but I figured unexpected behaviour warrants a bug.
- to me this is not really a regression from previous versions as the whole disk setup in 18 is way different than in 17 and before.

Comment 1 David Lehman 2013-04-10 20:01:45 UTC

*** This bug has been marked as a duplicate of bug 917880 ***


Note You need to log in before you can comment on or make changes to this bug.