Bug 928783 - eclipse crashes reliable in cairo_mask_surface
Summary: eclipse crashes reliable in cairo_mask_surface
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 18
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Alexander Kurtakov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-28 12:45 UTC by Thomas Meyer
Modified: 2013-12-10 08:55 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-10 08:55:57 UTC


Attachments (Terms of Use)
jvm crash log (128.40 KB, text/x-log)
2013-03-28 12:45 UTC, Thomas Meyer
no flags Details

Description Thomas Meyer 2013-03-28 12:45:29 UTC
Created attachment 717657 [details]
jvm crash log

Description of problem:

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. start eclipse
2. type "this." press ctrl+space -> crash

Comment 1 Thomas Meyer 2013-03-28 13:11:05 UTC
#0  0x00000031bd035ba5 in raise () from /lib64/libc.so.6
No symbol table info available.
#1  0x00000031bd037358 in abort () from /lib64/libc.so.6
No symbol table info available.
#2  0x00007ffff7a0a1b9 in os::abort (dump_core=true)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:1588
No locals.
#3  0x00007ffff7b66c1f in VMError::report_and_die (this=0x7ffff73042a0)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/utilities/vmError.cpp:1018
        skip_os_abort = true
        buffer = "/home/thomas/hs_err_pid16279.log", '\000' <repeats 1967 times>
        out = {<outputStream> = {<ResourceObj> = {<No data fields>}, _vptr.outputStream = 0x7ffff7f7cb70 <vtable for fdStream+16>, 
            _indentation = 0, _width = 80, _position = 0, _newlines = 21, _precount = 793, _stamp = {_counter = 0}}, _fd = 1, 
          _need_close = false}
        skip_OnError = false
        skip_bug_url = true
        out_done = true
        log_done = true
        transmit_report_done = true
        recursive_error_count = 0
        log = {<outputStream> = {<ResourceObj> = {<No data fields>}, _vptr.outputStream = 0x7ffff7f7cb70 <vtable for fdStream+16>, 
            _indentation = 0, _width = 80, _position = 0, _newlines = 1354, _precount = 131484, _stamp = {_counter = 0}}, _fd = 
    -1, _need_close = false}
        mytid = <optimized out>
#4  0x00007ffff7a1153f in JVM_handle_linux_signal (sig=11, info=0x7ffff73044f0, ucVoid=0x7ffff73043c0, abort_if_unrecognized=1)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os_cpu/linux_x86/vm/os_linux_x86.cpp:528
        uc = 0x7ffff73043c0
        thread = <optimized out>
        stub = <optimized out>
        newset = {__val = {1024, 0 <repeats 15 times>}}
        err = {<StackObj> = {<No data fields>}, _id = 11, _message = 0x0, _detail_msg = 0x0, _thread = 0x7ffff0008000, _pc = 
    0x7fffbe51c92e <WebKit::core(_WebKitWebView*)+14> "H\213", _siginfo = 0x7ffff73044f0, _context = 0x7ffff73043c0, _filename = 
    0x0, _lineno = 0, _current_step = 0, _current_step_info = 0x7ffff7b82edf "", _verbose = 1, static first_error = 
    0x7ffff73042a0, static first_error_tid = 140737340532480, static coredump_status = true, static coredump_message = 
    "/home/thomas/core or core.16279", '\000' <repeats 1968 times>, _size = 0}
        t = 0x7ffff0008000
        shm = {<StackObj> = {<No data fields>}, _thread = 0x7ffff0008000}
        vmthread = 0x0
        pc = <optimized out>
#5  <signal handler called>
No symbol table info available.
#6  0x00007fffbe51c92e in WebKit::core () from /lib64/libwebkitgtk-1.0.so.0
No locals.
#7  0x00007fffbe4ef8f8 in WebKit::GtkAdjustmentWatcher::updateAdjustmentsFromScrollbars () from /lib64/libwebkitgtk-1.0.so.0
No locals.
#8  0x00007fffbe4ef979 in updateAdjustmentCallback () from /lib64/libwebkitgtk-1.0.so.0
No locals.
#9  0x0000003200e481eb in g_timeout_dispatch (source=source@entry=0x7ffff2276500, callback=<optimized out>, 
    user_data=<optimized out>) at gmain.c:4026
        timeout_source = 0x7ffff2276500
        again = <optimized out>
#10 0x0000003200e47665 in g_main_dispatch (context=0x7ffff0253390) at gmain.c:2715
        dispatch = 0x3200e481d0 <g_timeout_dispatch>
        was_in_call = 0
        user_data = 0x7ffff2288c10
        callback = 0x7fffbe4ef970 <updateAdjustmentCallback()>
        cb_funcs = 0x3201120980 <g_source_callback_funcs>
        cb_data = 0x7ffff2275d00
        current_source_link = {data = 0x7ffff2276500, next = 0x0}
        need_destroy = <optimized out>
        source = 0x7ffff2276500
        current = 0x7ffff02e4800
        i = 8
#11 g_main_context_dispatch (context=context@entry=0x7ffff0253390) at gmain.c:3219
No locals.
#12 0x0000003200e47998 in g_main_context_iterate (context=context@entry=0x7ffff0253390, block=block@entry=0, 
    dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3290
        max_priority = 0
        timeout = 0
        some_ready = 1
        nfds = <optimized out>
        allocated_nfds = <optimized out>
        fds = 0x7ffff02e37c0
#13 0x0000003200e47a54 in g_main_context_iteration (context=0x7ffff0253390, may_block=0) at gmain.c:3351
        retval = <optimized out>
#14 0x00007fffecdc755c in Java_org_eclipse_swt_internal_gtk_OS__1g_1main_1context_1iteration (env=<optimized out>, 
    that=<optimized out>, arg0=<optimized out>, arg1=<optimized out>) at os.c:3646
        rc = 0 '\000'
#15 0x00007fffed550c76 in ?? ()
No symbol table info available.
#16 0x00000000f0826f15 in ?? ()
No symbol table info available.
#17 0x00007ffff73049f8 in ?? ()
No symbol table info available.
#18 0x00000000f0d5b6b0 in ?? ()
No symbol table info available.
#19 0x00000000f208e198 in ?? ()
No symbol table info available.
#20 0x00000000f0826f38 in ?? ()
No symbol table info available.
#21 0x0000000000000000 in ?? ()
No symbol table info available.

Comment 3 Thomas Meyer 2013-03-31 21:12:50 UTC
For better debugging using these Fedora 19 packages now:
$ yum list installed '*fc19*'
Geladene Plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
Installierte Pakete
libicu.x86_64                                    50.1.2-5.fc19                       installed
webkitgtk.x86_64                                 1.10.2-6.fc19                       installed
webkitgtk-debuginfo.x86_64                       1.10.2-6.fc19                       installed
webkitgtk-devel.x86_64                           1.10.2-6.fc19                       installed

Backtrace:
Thread 40 (Thread 0x7f89a928f700 (LWP 11184)):
#0  0x00000031bdc0eba7 in waitpid () from /lib64/libpthread.so.0
No symbol table info available.
#1  0x00007f89a999942d in os::fork_and_exec (cmd=<optimized out>)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os/linux/vm/os_linux.cpp:5411
        status = <optimized out>
        argv = {0x7f89a9b4782c "sh", 0x7f89a9b47824 "-c", 0x7f89a9f5c080 <VMError::report_and_die()::buffer> "gdb - 11183", 
    0x0}
        pid = 11280
#2  0x00007f89a9aeffcd in VMError::report_and_die (this=0x7f89a928d220)
    at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/share/vm/utilities/vmError.cpp:997
        ptr = 0x7f89a4002f78 ""
        buffer = "gdb - 11183\000/hs_err_pid11183.log", '\000' <repeats 1967 times>
        out = {<outputStream> = {<ResourceObj> = {<No data fields>}, 
            _vptr.outputStream = 0x7f89a9f05b70 <vtable for fdStream+16>, _indentation = 0, _width = 80, _position = 0, 
            _newlines = 17, _precount = 599, _stamp = {_counter = 0}}, _fd = 1, _need_close = false}
        skip_OnError = true
        skip_bug_url = false
        out_done = true
        log_done = true
        transmit_report_done = true
        recursive_error_count = 0
        log = {<outputStream> = {<ResourceObj> = {<No data fields>}, 
            _vptr.outputStream = 0x7f89a9f05b70 <vtable for fdStream+16>, _indentation = 0, _width = 80, _position = 0, 
            _newlines = 1398, _precount = 134324, _stamp = {_counter = 0}}, _fd = -1, _need_close = false}
        mytid = <optimized out>
#3  0x00007f89a999a53f in JVM_handle_linux_signal (sig=11, info=0x7f89a928d470, ucVoid=0x7f89a928d340, abort_if_unrecognized=
    1) at /usr/src/debug/java-1.7.0-openjdk/openjdk/hotspot/src/os_cpu/linux_x86/vm/os_linux_x86.cpp:528
        uc = 0x7f89a928d340
        thread = <optimized out>
        stub = <optimized out>
        newset = {__val = {1024, 0 <repeats 15 times>}}
        err = {<StackObj> = {<No data fields>}, _id = 11, _message = 0x0, _detail_msg = 0x0, _thread = 0x7f89a4007800, _pc = 
    0x7f8971b0c80e <WebKit::core(_WebKitWebView*)+14> "H\213", _siginfo = 0x7f89a928d470, _context = 0x7f89a928d340, 
          _filename = 0x0, _lineno = 0, _current_step = 0, _current_step_info = 0x7f89a9b0bedf "", _verbose = 1, 
          static first_error = 0x7f89a928d220, static first_error_tid = 140229225281280, static coredump_status = true, 
          static coredump_message = "/home/thomas/core or core.11183", '\000' <repeats 1968 times>, _size = 0}
        t = 0x7f89a4007800
        shm = {<StackObj> = {<No data fields>}, _thread = 0x7f89a4007800}
        vmthread = 0x0
        pc = <optimized out>
#4  <signal handler called>
No symbol table info available.
#5  0x00007f8971b0c80e in WebKit::core (webView=0x7f89a5f540d0) at Source/WebKit/gtk/webkit/webkitwebview.cpp:5363
        priv = 0xaaaaaaaaaaaaaaaa
#6  0x00007f8971adfcc8 in WebKit::GtkAdjustmentWatcher::updateAdjustmentsFromScrollbars (this=<optimized out>)
    at Source/WebKit/gtk/WebCoreSupport/GtkAdjustmentWatcher.cpp:65
No locals.
#7  0x00007f8971adfd39 in WebKit::updateAdjustmentCallback (watcher=<optimized out>)
    at Source/WebKit/gtk/WebCoreSupport/GtkAdjustmentWatcher.cpp:76
No locals.
#8  0x0000003200e481eb in g_timeout_dispatch (source=source@entry=0x7f89a5e72770, callback=<optimized out>, 
    user_data=<optimized out>) at gmain.c:4026
        timeout_source = 0x7f89a5e72770
        again = <optimized out>
#9  0x0000003200e47665 in g_main_dispatch (context=0x7f89a4252b10) at gmain.c:2715
        dispatch = 0x3200e481d0 <g_timeout_dispatch>
        was_in_call = 0
        user_data = 0x7f89a5f52e30
        callback = 0x7f8971adfd30 <WebKit::updateAdjustmentCallback(WebKit::GtkAdjustmentWatcher*)>
        cb_funcs = 0x3201120980 <g_source_callback_funcs>
        cb_data = 0x7f89a5e57180
        current_source_link = {data = 0x7f89a5e72770, next = 0x0}
        need_destroy = <optimized out>
        source = 0x7f89a5e72770
        current = 0x7f89a42e2d00
        i = 8
#10 g_main_context_dispatch (context=context@entry=0x7f89a4252b10) at gmain.c:3219
No locals.
#11 0x0000003200e47998 in g_main_context_iterate (context=context@entry=0x7f89a4252b10, block=block@entry=0, 
    dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3290
        max_priority = 0
        timeout = 0
        some_ready = 1
        nfds = <optimized out>
        allocated_nfds = <optimized out>
        fds = 0x7f89a42e2fc0
#12 0x0000003200e47a54 in g_main_context_iteration (context=0x7f89a4252b10, may_block=0) at gmain.c:3351
        retval = <optimized out>
#13 0x00007f898ca6155c in Java_org_eclipse_swt_internal_gtk_OS__1g_1main_1context_1iteration (env=<optimized out>, 
    that=<optimized out>, arg0=<optimized out>, arg1=<optimized out>) at os.c:3646
        rc = 0 '\000'
#14 0x00007f89a1011f50 in ?? ()
No symbol table info available.
#15 0x00007f89a4007360 in ?? ()
No symbol table info available.
#16 0x00000000f0811368 in ?? ()
No symbol table info available.
#17 0x00007f89a928e220 in ?? ()
No symbol table info available.
#18 0x00007f89a928d958 in ?? ()
No symbol table info available.
#19 0x0000000000000000 in ?? ()
No symbol table info available.


Source code:

(gdb) list Source/WebKit/gtk/webkit/webkitwebview.cpp:5363
5358	{
5359	    if (!webView)
5360	        return 0;
5361	
5362	    WebKitWebViewPrivate* priv = webView->priv;
-> 5363	    return priv ? priv->corePage : 0;
5364	}
5365	
5366	WebKitWebView* kit(WebCore::Page* corePage)
5367	{

It looks like the webView is not initialized yet!

webView = 0x7f89a5f540d0 - sizeof is 120 bytes.

Dump:
0x7f89a5f540d0:	0x00	0x00	0x00	0x00	0x00	0x00	0x00	0x00
0x7f89a5f540d8:	0x00	0x00	0x00	0x00	0x00	0x00	0x00	0x00
0x7f89a5f540e0:	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa
0x7f89a5f540e8:	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa
0x7f89a5f540f0:	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa
0x7f89a5f540f8:	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa
0x7f89a5f54100:	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa
0x7f89a5f54108:	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa
0x7f89a5f54110:	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa
0x7f89a5f54118:	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa
0x7f89a5f54120:	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa
0x7f89a5f54128:	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa
0x7f89a5f54130:	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa
0x7f89a5f54138:	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa
0x7f89a5f54140:	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa	0xaa

It looks like some locking/synchronisation is missing in the callback handler.

what do you think?

Comment 4 Thomas Meyer 2013-04-01 15:37:42 UTC
Okay. The WebKitWebView object is freed, and later still used in the CallbackHandler, looks like a race. This crash seems only to occur shortly after starting up eclipse. later on it works correctly, maybe due to high cpu usage of eclipse startup.

[New Thread 0x7fff7e4af700 (LWP 8759)]
Hardware watchpoint 3: ((WebKitWebView*) 0x7ffff1e9a110)->priv

Old value = (WebKitWebViewPrivate *) 0x7ffff1e9a190
New value = (WebKitWebViewPrivate *) 0xaaaaaaaaaaaaaaaa
0x00007ffff768d572 in __memset_sse2 () from /lib64/libc.so.6


#0  0x00007ffff768d572 in __memset_sse2 () from /lib64/libc.so.6
No symbol table info available.
#1  0x0000003201630e4e in g_type_free_instance (instance=<optimized out>) at gtype.c:1933
        node = 0x7ffff0561880
        class = <optimized out>
        __PRETTY_FUNCTION__ = "g_type_free_instance"
#2  0x00000037653bc4cf in gtk_scrolled_window_forall () from /lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#3  0x00000037652c23e7 in gtk_container_destroy () from /lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#4  0x000000320160f8de in g_closure_invoke (closure=closure@entry=0x7ffff0257d90, return_value=return_value@entry=0x0, n_param_values=1, param_values=param_values@entry=
    0x7ffff7fd0a60, invocation_hint=invocation_hint@entry=0x7ffff7fd0a00) at gclosure.c:777
        marshal = 0x320160e600 <g_type_class_meta_marshal>
        marshal_data = 0x98
        in_marshal = 1
        real_closure = 0x7ffff0257d70
        __PRETTY_FUNCTION__ = "g_closure_invoke"
#5  0x0000003201621c65 in signal_emit_unlocked_R (node=<optimized out>, detail=<optimized out>, instance=<optimized out>, emission_return=<optimized out>, 
    instance_and_params=<optimized out>) at gsignal.c:3667
        need_unset = <optimized out>
        accumulator = <optimized out>
        emission = {next = 0x7ffff7fd0f50, instance = 0x7ffff1612c90, ihint = {signal_id = 11, detail = 0, run_type = G_SIGNAL_RUN_CLEANUP}, state = EMISSION_STOP, 
          chain_type = 140737222819616}
        class_closure = 0x7ffff0257d90
        hlist = 0x0
        handler_list = <optimized out>
        return_accu = <optimized out>
        accu = {g_type = 0, data = {{v_int = 0, v_uint = 0, v_long = 0, v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, v_pointer = 0x0}, {v_int = 0, 
              v_uint = 0, v_long = 0, v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, v_pointer = 0x0}}}
        signal_id = <optimized out>
        max_sequential_handler_number = <optimized out>
        return_value_altered = <optimized out>
#6  0x0000003201629b0e in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=<optimized out>) at gsignal.c:3300
        instance_and_params = <optimized out>
        signal_return_type = <optimized out>
        param_values = <optimized out>
        node = 0x7ffff0258530
        i = <optimized out>
        n_params = <optimized out>
        __PRETTY_FUNCTION__ = "g_signal_emit_valist"
#7  0x0000003201629d02 in g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>) at gsignal.c:3356
        var_args = {{gp_offset = 24, fp_offset = 48, overflow_arg_area = 0x7ffff7fd0d70, reg_save_area = 0x7ffff7fd0cb0}}
#8  0x000000376537bc4e in gtk_object_dispose () from /lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#9  0x0000003201615cf1 in g_object_run_dispose (object=<optimized out>) at gobject.c:1062
        __PRETTY_FUNCTION__ = "g_object_run_dispose"
#10 0x0000003765303850 in gtk_fixed_forall () from /lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#11 0x00000037652c23e7 in gtk_container_destroy () from /lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#12 0x000000320160f9a0 in g_closure_invoke (closure=closure@entry=0x7ffff0257d90, return_value=return_value@entry=0x0, n_param_values=1, param_values=param_values@entry=
    0x7ffff7fd0fc0, invocation_hint=invocation_hint@entry=0x7ffff7fd0f60) at gclosure.c:777
        marshal = 0x320160e600 <g_type_class_meta_marshal>
        marshal_data = 0x98
        in_marshal = 0
        real_closure = 0x7ffff0257d70
        __PRETTY_FUNCTION__ = "g_closure_invoke"
#13 0x0000003201621c65 in signal_emit_unlocked_R (node=<optimized out>, detail=<optimized out>, instance=<optimized out>, emission_return=<optimized out>, 
    instance_and_params=<optimized out>) at gsignal.c:3667
        need_unset = <optimized out>
        accumulator = <optimized out>
        emission = {next = 0x0, instance = 0x7ffff1d98c80, ihint = {signal_id = 11, detail = 0, run_type = G_SIGNAL_RUN_CLEANUP}, state = EMISSION_STOP, chain_type = 
    140737222430208}
        class_closure = 0x7ffff0257d90
        hlist = 0x0
        handler_list = <optimized out>
        return_accu = <optimized out>
        accu = {g_type = 0, data = {{v_int = 0, v_uint = 0, v_long = 0, v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, v_pointer = 0x0}, {v_int = 0, 
              v_uint = 0, v_long = 0, v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, v_pointer = 0x0}}}
        signal_id = <optimized out>
        max_sequential_handler_number = <optimized out>
        return_value_altered = <optimized out>
#14 0x0000003201629b0e in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=<optimized out>) at gsignal.c:3300
        instance_and_params = <optimized out>
        signal_return_type = <optimized out>
        param_values = <optimized out>
        node = 0x7ffff0258530
        i = <optimized out>
        n_params = <optimized out>
        __PRETTY_FUNCTION__ = "g_signal_emit_valist"
#15 0x0000003201629d02 in g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>) at gsignal.c:3356
        var_args = {{gp_offset = 24, fp_offset = 48, overflow_arg_area = 0x7ffff7fd12d0, reg_save_area = 0x7ffff7fd1210}}
#16 0x000000376537bc4e in gtk_object_dispose () from /lib64/libgtk-x11-2.0.so.0
No symbol table info available.
#17 0x0000003201615cf1 in g_object_run_dispose (object=<optimized out>) at gobject.c:1062
        __PRETTY_FUNCTION__ = "g_object_run_dispose"
#18 0x00007fffd9662923 in Java_org_eclipse_swt_internal_gtk_OS__1gtk_1widget_1destroy (env=<optimized out>, that=<optimized out>, arg0=<optimized out>) at os.c:16393
No locals.
#19 0x00007fffed011f50 in ?? ()
No symbol table info available.
#20 0x00007ffff7fd1350 in ?? ()
No symbol table info available.
#21 0x00000000f0e99040 in ?? ()
No symbol table info available.
#22 0x0000000000000000 in ?? ()
No symbol table info available.

Comment 5 Thomas Meyer 2013-04-01 17:36:37 UTC
The sequence seems to be:

1.) Breakpoint 1, webkit_web_view_init (webView=0x7ffff1f90060) at Source/WebKit/gtk/webkit/webkitwebview.cpp:3597
3597	{

2.) Breakpoint 4, WebKit::GtkAdjustmentWatcher::updateAdjustmentsFromScrollbars (this=0x7ffff1f8f340) at Source/WebKit/gtk/WebCoreSupport/GtkAdjustmentWatcher.cpp:60
60	{

3.) Breakpoint 4, WebKit::GtkAdjustmentWatcher::updateAdjustmentsFromScrollbars (this=0x7ffff1f8f340) at Source/WebKit/gtk/WebCoreSupport/GtkAdjustmentWatcher.cpp:60
60	{

4.) Breakpoint 4, WebKit::GtkAdjustmentWatcher::updateAdjustmentsFromScrollbars (this=0x7ffff1f8f340) at Source/WebKit/gtk/WebCoreSupport/GtkAdjustmentWatcher.cpp:60
60	{

5.) Breakpoint 2, webkit_web_view_dispose (object=0x7ffff1f90060) at Source/WebKit/gtk/webkit/webkitwebview.cpp:1346
1346	{

#0  webkit_web_view_dispose (object=0x7ffff1f90060) at Source/WebKit/gtk/webkit/webkitwebview.cpp:1346
#1  0x0000003201615cf1 in g_object_run_dispose (object=<optimized out>) at gobject.c:1062
#2  0x00000037653bc4cf in gtk_scrolled_window_forall () from /lib64/libgtk-x11-2.0.so.0
#3  0x00000037652c23e7 in gtk_container_destroy () from /lib64/libgtk-x11-2.0.so.0
#4  0x000000320160f8de in g_closure_invoke (closure=closure@entry=0x7ffff0257d90, return_value=return_value@entry=0x0, n_param_values=1, param_values=param_values@entry=
    0x7ffff7fd0a60, invocation_hint=invocation_hint@entry=0x7ffff7fd0a00) at gclosure.c:777
#5  0x0000003201621c65 in signal_emit_unlocked_R (node=<optimized out>, detail=<optimized out>, instance=<optimized out>, emission_return=<optimized out>, 
    instance_and_params=<optimized out>) at gsignal.c:3667
#6  0x0000003201629b0e in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=<optimized out>) at gsignal.c:3300
#7  0x0000003201629d02 in g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>) at gsignal.c:3356
#8  0x000000376537bc4e in gtk_object_dispose () from /lib64/libgtk-x11-2.0.so.0
#9  0x0000003201615cf1 in g_object_run_dispose (object=<optimized out>) at gobject.c:1062
#10 0x0000003765303850 in gtk_fixed_forall () from /lib64/libgtk-x11-2.0.so.0
#11 0x00000037652c23e7 in gtk_container_destroy () from /lib64/libgtk-x11-2.0.so.0
#12 0x000000320160f9a0 in g_closure_invoke (closure=closure@entry=0x7ffff0257d90, return_value=return_value@entry=0x0, n_param_values=1, param_values=param_values@entry=
    0x7ffff7fd0fc0, invocation_hint=invocation_hint@entry=0x7ffff7fd0f60) at gclosure.c:777
#13 0x0000003201621c65 in signal_emit_unlocked_R (node=<optimized out>, detail=<optimized out>, instance=<optimized out>, emission_return=<optimized out>, 
    instance_and_params=<optimized out>) at gsignal.c:3667
#14 0x0000003201629b0e in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=<optimized out>) at gsignal.c:3300
#15 0x0000003201629d02 in g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>) at gsignal.c:3356
#16 0x000000376537bc4e in gtk_object_dispose () from /lib64/libgtk-x11-2.0.so.0
#17 0x0000003201615cf1 in g_object_run_dispose (object=<optimized out>) at gobject.c:1062
#18 0x00007fffd9662923 in Java_org_eclipse_swt_internal_gtk_OS__1gtk_1widget_1destroy (env=<optimized out>, that=<optimized out>, arg0=<optimized out>) at os.c:16393
#19 0x00007fffed011f50 in ?? ()
#20 0x00007ffff7fd1350 in ?? ()
#21 0x00000000f0e99598 in ?? ()
#22 0x0000000000000000 in ?? ()

6.) Breakpoint 3, webkit_web_view_finalize (object=0x7ffff1f90060) at Source/WebKit/gtk/webkit/webkitwebview.cpp:1388
1388	{

-> Here the m_webView is set to 0xaa resp. 0x00

7.) Breakpoint 4, WebKit::GtkAdjustmentWatcher::updateAdjustmentsFromScrollbars (this=0x7ffff1f8f340) at Source/WebKit/gtk/WebCoreSupport/GtkAdjustmentWatcher.cpp:60
60	{

#0  WebKit::GtkAdjustmentWatcher::updateAdjustmentsFromScrollbars (this=0x7ffff1f8f340) at Source/WebKit/gtk/WebCoreSupport/GtkAdjustmentWatcher.cpp:60
#1  0x00000033e3fead39 in WebKit::updateAdjustmentCallback (watcher=<error reading variable: value has been optimized out>)
    at Source/WebKit/gtk/WebCoreSupport/GtkAdjustmentWatcher.cpp:76
#2  0x0000003200e481eb in g_timeout_dispatch (source=source@entry=0x7ffff1fb5480, callback=<optimized out>, user_data=<optimized out>) at gmain.c:4026
#3  0x0000003200e47665 in g_main_dispatch (context=0x7ffff0252ab0) at gmain.c:2715
#4  g_main_context_dispatch (context=context@entry=0x7ffff0252ab0) at gmain.c:3219
#5  0x0000003200e47998 in g_main_context_iterate (context=context@entry=0x7ffff0252ab0, block=block@entry=0, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3290
#6  0x0000003200e47a54 in g_main_context_iteration (context=0x7ffff0252ab0, may_block=0) at gmain.c:3351
#7  0x00007fffd964f55c in Java_org_eclipse_swt_internal_gtk_OS__1g_1main_1context_1iteration (env=<optimized out>, that=<optimized out>, arg0=<optimized out>, 
    arg1=<optimized out>) at os.c:3646
#8  0x00007fffed011f50 in ?? ()
#9  0x00007ffff0007310 in ?? ()
#10 0x00000000f0811368 in ?? ()
#11 0x00007ffff0007800 in ?? ()
#12 0x00007ffff7fd1958 in ?? ()
#13 0x0000000000000000 in ?? ()

Comment 6 Deepak Bhole 2013-04-03 18:21:28 UTC
Looks like issues arising from JNI code. Re-assigning to Eclipse.

Comment 7 Thomas Meyer 2013-04-28 10:20:56 UTC
Hello Alexander Kurtakov,

any ideas what could be wrong here?

Comment 8 Alexander Kurtakov 2013-04-29 06:37:03 UTC
Hi Thomas, 
One webkit crasher fix is available in the latest build eclipse-4.3.0-0.40.fc19 can you try with it and report whether same thing happens?
Webkitgtk 2.x is not officially supported upstream yet but work is ongoing - this should explain it a bit. FWIW, I can't reproduce this crash with latest build myself.

Comment 9 Thomas Meyer 2013-07-08 21:28:24 UTC
i switched to the upstream eclipse. eclipse kepler seems to work correctly for me.

Comment 10 Alexander Kurtakov 2013-07-08 21:41:25 UTC
Thomas, Fedora 19 has Kepler too. Is it crashing for you ?

Comment 11 Alexander Kurtakov 2013-12-10 08:55:57 UTC
Long time no response. Closing. Please reopen ifyou are ready to provide more information.


Note You need to log in before you can comment on or make changes to this bug.