Bug 928947 - samba-common = 2:3.6.12-1.fc17.1 is needed by (installed) samba-doc-2:3.6.12-1.fc17.1.x86_64
Summary: samba-common = 2:3.6.12-1.fc17.1 is needed by (installed) samba-doc-2:3.6.12-...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: samba
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Guenther Deschner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-28 19:17 UTC by Alan R. Parker
Modified: 2013-04-29 16:56 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-20 20:17:39 UTC


Attachments (Terms of Use)

Description Alan R. Parker 2013-03-28 19:17:12 UTC
Description of problem:

19:05:24 : YUM: Running Transaction Check
19:05:24 : ERROR: Error in yum Transaction : [u'ERROR with transaction check vs depsolve:', 'samba-common = 2:3.6.12-1.fc17.1 is needed by (installed) samba-doc-2:3.6.12-1.fc17.1.x86_64'


How reproducible:
Over the past few days when I launch yumex it reports a problem with samba

Steps to Reproduce:
1. Upgrade from fedora 17 to 18
2. Do daily updates for a few weeks
3. Try and update samba 
  
Actual results:
Reports fc17 dependancy, samba-common = 2:3.6.12-1.fc17.1

Expected results:

Upgraded to latest fc18 level, 2:4.0.3-2.fc18, 2:4.0.4-3.fc18 

Additional info:

19:03:01 : Starting yum child process
19:03:10 : YUM: Yum Version : 3.4.3
19:03:10 : YUM: Loaded plugins: presto
19:03:11 : Getting available updates
19:03:12 : Downloaded : fedora/18/x86_64/metalink ( 34 k )
19:03:12 : Downloaded : games_unknown-horizons ( 1.7 k )
19:03:13 : Downloaded : google-chrome ( 951  )
19:03:13 : Downloaded : rpmfusion-free-updates/18/x86_64 ( 3.3 k )
19:03:13 : Downloaded : rpmfusion-nonfree-updates/18/x86_64 ( 3.3 k )
19:03:14 : Downloaded : updates/18/x86_64/metalink ( 23 k )
19:03:19 : 9 packages returned
19:03:19 : Getting available obsoletes
19:03:19 : 0 packages returned
19:03:19 : Adding Packages to view
19:03:19 : Added 9 Packages to view
19:03:41 : YUM: --> Running transaction check
19:03:41 : YUM: ---> Package libmtp.x86_64 0:1.1.5-2.fc18 will be updated
19:03:41 : YUM: ---> Package libmtp.x86_64 0:1.1.6-0.fc18 will be an update
19:03:41 : YUM: ---> Package libmtp-devel.x86_64 0:1.1.5-2.fc18 will be updated
19:03:41 : YUM: ---> Package libmtp-devel.x86_64 0:1.1.6-0.fc18 will be an update
19:03:41 : YUM: ---> Package libmtp-examples.x86_64 0:1.1.5-2.fc18 will be updated
19:03:41 : YUM: ---> Package libmtp-examples.x86_64 0:1.1.6-0.fc18 will be an update
19:03:41 : YUM: ---> Package libsmbclient.x86_64 2:4.0.3-2.fc18 will be updated
19:03:41 : YUM: ---> Package libsmbclient.x86_64 2:4.0.4-3.fc18 will be an update
19:03:41 : YUM: ---> Package libwbclient.x86_64 2:4.0.3-2.fc18 will be updated
19:03:42 : YUM: ---> Package libwbclient.x86_64 2:4.0.4-3.fc18 will be an update
19:03:42 : YUM: ---> Package samba.x86_64 2:4.0.3-2.fc18 will be updated
19:03:42 : YUM: ---> Package samba.x86_64 2:4.0.4-3.fc18 will be an update
19:03:42 : YUM: ---> Package samba-client.x86_64 2:4.0.3-2.fc18 will be updated
19:03:42 : YUM: ---> Package samba-client.x86_64 2:4.0.4-3.fc18 will be an update
19:03:42 : YUM: ---> Package samba-common.x86_64 2:4.0.3-2.fc18 will be updated
19:03:43 : YUM: ---> Package samba-common.x86_64 2:4.0.4-3.fc18 will be an update
19:03:46 : YUM: ---> Package samba-libs.x86_64 2:4.0.3-2.fc18 will be updated
19:03:47 : YUM: ---> Package samba-libs.x86_64 2:4.0.4-3.fc18 will be an update
19:03:54 : YUM: --> Finished Dependency Resolution
19:05:23 : YUM: Setting up and reading Presto delta metadata
19:05:24 : Downloaded : (1/3): libmtp-1.1.6-0.fc18.x86_64.rpm ( 126 k )
19:05:24 : Downloaded : (2/3): libmtp-devel-1.1.6-0.fc18.x86_64.rpm ( 76 k )
19:05:24 : Downloaded : (3/3): libmtp-examples-1.1.6-0.fc18.x86_64.rpm ( 61 k )
19:05:24 : YUM: Running Transaction Check
19:05:24 : ERROR: Error in yum Transaction : [u'ERROR with transaction check vs depsolve:', 'samba-common = 2:3.6.12-1.fc17.1 is needed by (installed) samba-doc-2:3.6.12-1.fc17.1.x86_64', u'Please report this error at https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum']

Comment 1 Jan Zeleny 2013-03-29 09:25:03 UTC
Reassigning to samba, as this issue was caused by the upgrade. Yum is now only reporting pre-existing condition which it can't do anything about.

It seems that samba-doc subpackage was discontinued in Fedora 17 and it has not been removed during the upgrade (probably missing obsoletes?) - that's why you are stuck with current samba-common.

From yum perspective, the solution is to uninstall samba-doc subpackage.

Comment 2 Alan R. Parker 2013-03-29 09:36:10 UTC
I've confirmed erasing the old doc and allowing yum(ex) to apply the pending updates allows yum(ex) to complete.

Comment 3 Fedora Update System 2013-04-10 14:59:34 UTC
samba-4.0.5-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/samba-4.0.5-1.fc19

Comment 4 Fedora Update System 2013-04-10 15:27:13 UTC
samba-4.0.5-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/samba-4.0.5-1.fc18

Comment 5 Fedora Update System 2013-04-11 10:02:51 UTC
Package samba-4.0.5-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing samba-4.0.5-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5357/samba-4.0.5-1.fc18
then log in and leave karma (feedback).

Comment 6 Alan R. Parker 2013-04-12 05:41:25 UTC
Added the yum update from testing, no problems installing.
Had a subsequent yum(ex) update of new kernel + several other updates, again applied successfully.

Note I'd already erased the old doc package after earlier feedback so was not in a true state to confirm the original issue.

Comment 7 Fedora Update System 2013-04-20 20:17:41 UTC
samba-4.0.5-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2013-04-24 01:29:32 UTC
samba-4.0.5-1.fc18, freeipa-3.1.3-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 franck.bailliet 2013-04-29 02:16:22 UTC
(In reply to comment #8)
> samba-4.0.5-1.fc18, freeipa-3.1.3-5.fc18 has been pushed to the Fedora 18
> stable repository.  If problems still persist, please make note of it in
> this bug report.

I did install rpm packages samba-4.0.5-1.fc18 and freeipa-3.1.3-5.fc18 put the matter still persists...

Comment 10 franck.bailliet 2013-04-29 16:42:51 UTC
Frankyboy : "the problem still persists"

Test de la transaction en cours
ERREUR lors de la vérification de la transaction avec les dépendances :
samba-common = 2:3.6.12-1.fc17.1 is needed by (installed) samba-domainjoin-gui-2:3.6.12-1.fc17.1.x86_64
Veuillez reporter cette erreur dans https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
** 9 problèmes RPMDB préexistants trouvés, la sortie de « yum check » est la suivante :
clamav-milter-systemd-0.97.7-1.fc17.noarch a des dépendances manquantes de clamav-milter = ('0', '0.97.7', '1.fc17')
clamav-milter-systemd-0.97.7-1.fc18.noarch est un doublon de clamav-milter-systemd-0.97.7-1.fc17.noarch
clamav-scanner-systemd-0.97.7-1.fc17.noarch a des dépendances manquantes de clamav-scanner = ('0', '0.97.7', '1.fc17')
clamav-scanner-systemd-0.97.7-1.fc17.noarch a des dépendances manquantes de clamav-server-systemd = ('0', '0.97.7', '1.fc17')
clamav-scanner-systemd-0.97.7-1.fc18.noarch est un doublon de clamav-scanner-systemd-0.97.7-1.fc17.noarch
cnijfilter-mp280series-3.40-1.x86_64 a des dépendances manquantes de libtiff.so.3()(64bit)
dpm-perl-1.8.6-1.fc17.x86_64 a des dépendances manquantes de perl(:MODULE_COMPAT_5.14.3)
msttcorefonts-1.3-4.noarch a des dépendances manquantes de /usr/sbin/chkfontpath
2:samba-domainjoin-gui-3.6.12-1.fc17.1.x86_64 a des dépendances manquantes de samba-common = ('2', '3.6.12', '1.fc17.1')

Comment 11 franck.bailliet 2013-04-29 16:56:56 UTC
[root@Swann Téléchargements]# yum reinstall samba-common
Modules complémentaires chargés : langpacks, presto, refresh-packagekit
Paquets installés 2:samba-common-4.0.4-3.fc18.x86_64 indisponibles.
Erreur : Rien à faire


Note You need to log in before you can comment on or make changes to this bug.