Bug 929037 - RHEL5 host: rhel6.4 guest cannot start to Desktop because qxl Segmentation fault
Summary: RHEL5 host: rhel6.4 guest cannot start to Desktop because qxl Segmentation fault
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-qxl
Version: 6.5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Søren Sandmann Pedersen
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
: 904956 (view as bug list)
Depends On:
Blocks: 960058
TreeView+ depends on / blocked
 
Reported: 2013-03-29 05:38 UTC by ShupingCui
Modified: 2018-12-03 18:34 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-11-21 20:48:37 UTC


Attachments (Terms of Use)
screenshot (843.76 KB, image/x-portable-pixmap)
2013-03-29 05:44 UTC, ShupingCui
no flags Details
Xorg.0.log (40.67 KB, text/x-log)
2013-03-29 05:45 UTC, ShupingCui
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1650 normal SHIPPED_LIVE xorg-x11-drv-qxl bug fix update 2013-11-20 21:53:23 UTC

Description ShupingCui 2013-03-29 05:38:58 UTC
Description of problem:

rhel6.4 guest cannot start to Desktop because qxl Segmentation fault.

Version-Release number of selected component (if applicable):

Host:
kernel-2.6.18-348.3.1.el5
kvm-83-262.el5_9.2

Guest:
kernel-2.6.32-358.el6.x86_64
xorg-x11-drv-qxl-0.1.0-4.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. boot guest
/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/qemu -name 'vm1' -monitor unix:'/tmp/monitor-humanmonitor1-20130328-095730-BfYYJuaF',server,nowait -serial unix:'/tmp/serial-serial1-20130328-095730-BfYYJuaF',server,nowait -drive file='/usr/local/staf/test/RHEV/kvm/autotest-devel/client/tests/kvm/images/RHEL-Server-6.4-64-virtio.qcow2',if=virtio,media=disk,cache=none,boot=on,snapshot=off,format=qcow2 -net nic,vlan=0,model=virtio,macaddr='9a:20:21:22:23:24',id='idpJLTMc' -net tap,vlan=0 -m 4096 -smp 1,cores=1,threads=1,sockets=2 -cpu 'qemu64' -M rhel5.6.0 -soundhw ac97 -spice port=3100,ic=on,disable-ticketing -qxl 1 -rtc-td-hack -boot c -no-kvm-pit-reinjection -usbdevice tablet -monitor stdio

2. 
3. 
  
Actual results:
guest cannot start to Desktop

Expected results:
guest start to Desktop, wait for user login

Additional info:
1. wait 1 min, press "Alt+F2"
2. login guest, start x window using cmd: startx
3. got Segmentation fault
4. cat /var/log/Xorg.0.log

Comment 1 ShupingCui 2013-03-29 05:44:11 UTC
Created attachment 717951 [details]
screenshot

guest got this interface, cannot start to desktop

Comment 2 ShupingCui 2013-03-29 05:45:00 UTC
Created attachment 717952 [details]
Xorg.0.log

Comment 6 Marian Krcmarik 2013-09-09 12:43:37 UTC
*** Bug 904956 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2013-11-21 20:48:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1650.html


Note You need to log in before you can comment on or make changes to this bug.