Bug 929068 - Mice "QEMU HID Tablet" won't work with Q35
Summary: Mice "QEMU HID Tablet" won't work with Q35
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Miroslav Rezanina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-29 08:01 UTC by Shaolong Hu
Modified: 2014-06-18 03:26 UTC (History)
9 users (show)

Fixed In Version: qemu-kvm-1.5.0-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 10:23:29 UTC


Attachments (Terms of Use)
[PATCH] usb-tablet: Don't claim wakeup capability for USB-2 version (1.07 KB, patch)
2013-04-02 17:14 UTC, Hans de Goede
no flags Details | Diff

Description Shaolong Hu 2013-03-29 08:01:03 UTC
Description of problem:
----------------------------
As subject.


Version-Release number of selected component (if applicable):
----------------------------------------------------------------
qemu-kvm-1.4.0-1.el7.x86_64


How reproducible:
-------------------
100%


Steps to Reproduce:
---------------------
1.boot guest with:
/usr/libexec/qemu-kvm -enable-kvm -smp 4 -m 4G -name rhel6.3-64 -uuid 3f2ea5cd-3d29-48ff-aab2-23df1b6ae213 -drive file=nfs/RHEL-Server-6.4-64-virtio.qcow2,cache=none,if=none,rerror=stop,werror=stop,id=drive-virtio-disk0,format=qcow2 -device virtio-blk-pci,drive=drive-virtio-disk0,id=device-virtio-disk0 -boot order=cd,once=n -monitor stdio -usb -device usb-tablet,id=input0 -chardev socket,id=s1,path=/tmp/s1,server,nowait -device isa-serial,chardev=s1 -monitor tcp::1234,server,nowait -spice disable-ticketing,port=5920 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -vga qxl -global qxl-vga.vram_size=33554432 -qmp tcp:0:5555,server,nowait -netdev tap,script=/etc/qemu-ifup,id=netdev0,vhost=on,queues=4,vhostforce=off -device virtio-net-pci,netdev=netdev0,id=device-net0,mac=aa:54:00:11:22:33,vectors=9,mq=on -M q35

2.
(qemu) info mice
  Mouse #0: QEMU PS/2 Mouse
* Mouse #1: QEMU HID Tablet (absolute)

  
Actual results:
----------------
Mice does not work(move correctly, won't response to click), without "-M q35", it's fine.

Comment 2 Gerd Hoffmann 2013-04-02 12:17:18 UTC
any change if you use "-device usb-tablet,id=input0,usb_version=1" ?

Comment 3 Shaolong Hu 2013-04-02 15:02:55 UTC
(In reply to comment #2)
> any change if you use "-device usb-tablet,id=input0,usb_version=1" ?

It works.

Comment 4 Gerd Hoffmann 2013-04-02 15:56:34 UTC
Hans, looks like (some?) windows guests have trouble with the usb2 tablet.
Any idea what this might be?

Comment 5 Hans de Goede 2013-04-02 17:13:09 UTC
Hi,

(In reply to comment #4)
> Hans, looks like (some?) windows guests have trouble with the usb2 tablet.

Actually looking at the cmdline this is with a RHEL-6 guest.
 
> Any idea what this might be?

I've run some tests and it is caused by the use of usb-wakeup with our ehci emulation, which does not support wakeup.

I've just send a patch to the qemu-devel list fixing this.

Regards,

Hans

Comment 6 Hans de Goede 2013-04-02 17:14:49 UTC
Created attachment 730868 [details]
[PATCH] usb-tablet: Don't claim wakeup capability for USB-2 version

Comment 8 Miroslav Rezanina 2013-05-23 12:07:16 UTC
Build in qemu-kvm-1.5.0-1.el7

Comment 10 Shaolong Hu 2014-01-24 08:59:25 UTC
Verified on qemu-kvm-rhev-1.5.3-39.el7.x86_64 with RHEL7 guest, mice works correctly with Q35.

Comment 11 Ludek Smid 2014-06-13 10:23:29 UTC
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.


Note You need to log in before you can comment on or make changes to this bug.