Bug 9291 - netscape loses input focus with combo box in html form
Summary: netscape loses input focus with combo box in html form
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: enlightenment   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-10 05:22 UTC by jstrand1
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 20:36:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jstrand1 2000-02-10 05:22:56 UTC
Problem:

When entering information into a plain html form with a combo box, if the
combo box has too many entries to display on the screen (eg a combo box
listing the 50 states of USA) and you have to click 'More' to see the rest,
and choose one from these (eg to pick 'Utah'), then netscape loses the
input focus and you cannot enter more information into the form with the
keyboard (though you can move the cursor to different areas of the form
with the mouse).  However, the netscape window is highlighted, as if it had
the focus.  You have to click on another application window (eg 'xterm')
then click back on netscape to get the input focus back to netscape to
enter information in the form with the keyboard.  This behavior was
observed using Gnome/Enlightenment and icewm (without gnome).  Oddly,
netscape works properly in kde.  I am using all the latest packages per the
RedHat 6.1 errata (including netscape 4.70-1 and all gnome packages).

My feeling is that it is not netscape since netscape works fine in kde, but
instead the window managers in question and/or X when used in conjunction
with the window managers.

Comment 1 Preston Brown 2000-02-10 20:36:59 UTC
no, this is a longstanding netscape bug that will likely not get fixed.  KDE has
some workarounds.

The simple solution is to minimize and then restore netscape.  Focus will be
returned.


Note You need to log in before you can comment on or make changes to this bug.