Bug 929119 - Partitioning commands not written to anaconda-ks.cfg
Partitioning commands not written to anaconda-ks.cfg
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
19
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
: 965861 (view as bug list)
Depends On:
Blocks: 888841 fedora19rtt
  Show dependency treegraph
 
Reported: 2013-03-29 05:50 EDT by Jan Stodola
Modified: 2013-06-18 02:15 EDT (History)
10 users (show)

See Also:
Fixed In Version: pykickstart-1.99.32-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 02:15:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (28.44 KB, text/plain)
2013-03-29 05:52 EDT, Jan Stodola
no flags Details
anaconda.packaging.log (704.66 KB, text/plain)
2013-03-29 05:52 EDT, Jan Stodola
no flags Details
anaconda.program.log (36.86 KB, text/plain)
2013-03-29 05:52 EDT, Jan Stodola
no flags Details
anaconda.storage.log (169.42 KB, text/plain)
2013-03-29 05:52 EDT, Jan Stodola
no flags Details
syslog (84.73 KB, text/plain)
2013-03-29 05:52 EDT, Jan Stodola
no flags Details
anaconda-ks.cfg (735 bytes, text/plain)
2013-03-29 05:59 EDT, Jan Stodola
no flags Details

  None (edit)
Description Jan Stodola 2013-03-29 05:50:09 EDT
Description of problem:
/root/anaconda-ks.cfg created by anaconda during installation doesn't contain partitioning commands like "part", "autopart", "logvol",....
On the other hand, commands "bootloader" and "clearpart" are there.

Version-Release number of selected component (if applicable):
F19-Alpha-TC3
anaconda-19.14
pykickstart-1.99.26

How reproducible:
always

Steps to Reproduce:
1. start graphical installation
2. proceed to custom partitioning
3. remove all previous partitions
4. let anaconda to create partitioning for you
5. or create your own partitioning
6. finish the installation and reboot to installed system
7. open /root/anaconda-ks.cfg
  
Actual results:
partitioning commands are missing

Expected results:
partitioning command are present in anaconda-ks.cfg
Comment 1 Jan Stodola 2013-03-29 05:52:01 EDT
Created attachment 717978 [details]
anaconda.log
Comment 2 Jan Stodola 2013-03-29 05:52:07 EDT
Created attachment 717980 [details]
anaconda.packaging.log
Comment 3 Jan Stodola 2013-03-29 05:52:11 EDT
Created attachment 717981 [details]
anaconda.program.log
Comment 4 Jan Stodola 2013-03-29 05:52:15 EDT
Created attachment 717982 [details]
anaconda.storage.log
Comment 5 Jan Stodola 2013-03-29 05:52:19 EDT
Created attachment 717983 [details]
syslog
Comment 6 Jan Stodola 2013-03-29 05:59:04 EDT
Created attachment 717998 [details]
anaconda-ks.cfg
Comment 7 Chris Lumens 2013-05-22 10:57:48 EDT
*** Bug 965861 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2013-06-14 12:45:01 EDT
pykickstart-1.99.32-1.fc19,python-blivet-0.16-1.fc19,anaconda-19.30.6-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pykickstart-1.99.32-1.fc19,python-blivet-0.16-1.fc19,anaconda-19.30.6-1.fc19
Comment 9 Fedora Update System 2013-06-15 13:06:44 EDT
Package anaconda-19.30.7-1.fc19, pykickstart-1.99.32-1.fc19, python-blivet-0.16-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.30.7-1.fc19 pykickstart-1.99.32-1.fc19 python-blivet-0.16-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10913/pykickstart-1.99.32-1.fc19,python-blivet-0.16-1.fc19,anaconda-19.30.7-1.fc19
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-06-18 02:15:52 EDT
pykickstart-1.99.32-1.fc19, python-blivet-0.16-1.fc19, anaconda-19.30.8-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.