Bug 929138 - Create User dialog can result in use of UID/GID of less than 1000
Summary: Create User dialog can result in use of UID/GID of less than 1000
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-29 10:10 UTC by Ed Greshko
Modified: 2013-04-09 03:39 UTC (History)
7 users (show)

Fixed In Version: anaconda-19.15-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-09 03:39:14 UTC
Type: Bug


Attachments (Terms of Use)

Description Ed Greshko 2013-03-29 10:10:24 UTC
Description of problem: On install one may be lead to create a new user with a UID or GID of less than 1000


Version-Release number of selected component (if applicable):


How reproducible: 


Steps to Reproduce:
1. Follow initial steps and then click "Begin Install".
2. When the install is starting, select the "Create User".
3. Fill out all the relevant information and then choose "Advanced"
4. In the "Advanced User Configuration" check the box for "Specify a user ID manually;
5. Click on either - or +
  
Actual results: The UID or GID shown will be 500 if you click the - or 501 if you click the +.


Expected results: Since UID should be 1000 or greater the results should be either 1000 or 1001.


Additional info:

Comment 1 Fedora Update System 2013-04-03 00:08:08 UTC
anaconda-19.15-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.15-1.fc19

Comment 2 Fedora Update System 2013-04-03 16:08:54 UTC
Package anaconda-19.15-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.15-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4754/anaconda-19.15-1.fc19
then log in and leave karma (feedback).

Comment 3 Fedora Update System 2013-04-05 00:51:29 UTC
anaconda-19.16-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.16-2.fc19

Comment 4 Fedora Update System 2013-04-09 03:39:16 UTC
anaconda-19.16-2.fc19, python-meh-0.22-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.