Bug 9292 - magicdev/mc interaction problem under GNOME.
magicdev/mc interaction problem under GNOME.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mc (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-10 02:38 EST by Neil Darlow
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-15 15:00:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Darlow 2000-02-10 02:38:17 EST
All errata updates installed (not rawhide ones).
CD-ROM using kernel SCSI emulation (don't know if this is significant).
magicdev configured to automount and display CD-ROM.

Synopsis: mc segfaults after CD-ROM change detected by magicdev.

Reproduced by:
1) Insert a CD-ROM into drive.
   mc window for /mnt/cdrom appears correctly.
2) Close mc window for /mnt/cdrom with x button.
3) umount /mnt/cdrom with "Disk Management" system utility.
4) Eject and place another CD-ROM into drive.
   mc displays a segment fault dialog.

mc appears robust under normal operation. This problem seems to
be magicdev related.
Comment 1 Preston Brown 2000-02-14 15:09:59 EST
jonathan -- please examine when you have a moment.
Comment 2 Neil Darlow 2000-02-15 03:20:59 EST
It appears that my original bug report must have coincided with my IDE CD-ROM
drive developing a fault.

This drive has since failed completely and has been replaced. The problem is
not reproducible with the new drive.

The symptoms of the failure were "Medium not found" errors from mount. The
Disk Management applet handled these errors ok but perhaps magicdev/mc didn't.

You can either treat this as resolved or investigate it further as a possible
weakness. It depends on your workload and point of view.
Comment 3 Jonathan Blandford 2000-02-15 12:08:59 EST
Forwarding to Owen, who helped write magic dev.  It's his choice what to do.
Comment 4 Owen Taylor 2000-02-15 15:00:59 EST
Closed as being non-reproducible. There may be some mishandling
of IO errors in MC, but it doesn't look worth pursuing at this
point.

Note You need to log in before you can comment on or make changes to this bug.