Bug 929204 - Anaconda creates group for user with GID 0
Anaconda creates group for user with GID 0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 955219 960565 (view as bug list)
Depends On:
Blocks: fedora19rtt
  Show dependency treegraph
 
Reported: 2013-03-29 09:44 EDT by Ľuboš Kardoš
Modified: 2013-05-24 17:17 EDT (History)
9 users (show)

See Also:
Fixed In Version: pykickstart-1.99.27-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 17:17:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/etc/group (517 bytes, application/octet-stream)
2013-03-29 09:48 EDT, Ľuboš Kardoš
no flags Details
/etc/passwd (1.19 KB, application/octet-stream)
2013-03-29 09:49 EDT, Ľuboš Kardoš
no flags Details
anaconda.log (12.66 KB, text/x-log)
2013-03-29 09:49 EDT, Ľuboš Kardoš
no flags Details
anaconda.packaging.log (706.75 KB, text/x-log)
2013-03-29 09:50 EDT, Ľuboš Kardoš
no flags Details
anaconda.program.log (39.39 KB, text/x-log)
2013-03-29 09:50 EDT, Ľuboš Kardoš
no flags Details

  None (edit)
Description Ľuboš Kardoš 2013-03-29 09:44:36 EDT
Description of problem:
Create user "test" during installation. Anaconda for this user creates group "test" with GID 0, which conflicts with group "root" also with GID 0. So when you login with user "test", command "groups" prints that you belongs to group "root" instead of group "test".


Version-Release number of selected component (if applicable):
F19-Alpha-TC3
anaconda-19.14

How reproducible:
always


Steps to Reproduce:
1. Start an installation and proceed to the "CREATE USER" spoke.
2. Fill out the form and confirm: 
     Full name: test 
     Username: test 
     Make this user administrator: unchecked
     Require a password to use this account: checked
     Password: redhat
     Confirm password: redhat
3. Finish the installation.
  
Actual results:
After reboot to the newly installed system, you can see in /etc/group following:
root:x:0:
...
test:x:0:test

Expected results:
GID for group "root" and "test" must not be the same.


Additional info:
Comment 1 Ľuboš Kardoš 2013-03-29 09:48:18 EDT
Created attachment 718081 [details]
/etc/group
Comment 2 Ľuboš Kardoš 2013-03-29 09:49:13 EDT
Created attachment 718082 [details]
/etc/passwd
Comment 3 Ľuboš Kardoš 2013-03-29 09:49:45 EDT
Created attachment 718083 [details]
anaconda.log
Comment 4 Ľuboš Kardoš 2013-03-29 09:50:17 EDT
Created attachment 718085 [details]
anaconda.packaging.log
Comment 5 Ľuboš Kardoš 2013-03-29 09:50:43 EDT
Created attachment 718086 [details]
anaconda.program.log
Comment 6 Chris Lumens 2013-04-01 16:01:17 EDT
This might require work outside pykickstart - not sure yet.  At the least, pykickstart should be defaulting to None instead of 0.
Comment 7 Chris Lumens 2013-04-22 15:50:33 EDT
*** Bug 955219 has been marked as a duplicate of this bug. ***
Comment 8 Chris Lumens 2013-05-08 09:37:16 EDT
*** Bug 960565 has been marked as a duplicate of this bug. ***
Comment 9 Brian Lane 2013-05-24 17:17:55 EDT
This is in the current stable version.

Note You need to log in before you can comment on or make changes to this bug.