Bug 929299 - Rescan of additionally inserted disks doesn't work in qemu-kvm
Rescan of additionally inserted disks doesn't work in qemu-kvm
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora19rtt
  Show dependency treegraph
 
Reported: 2013-03-29 12:06 EDT by Ľuboš Kardoš
Modified: 2016-07-31 21:26 EDT (History)
9 users (show)

See Also:
Fixed In Version: anaconda-19.30-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 16:18:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of dmesg (42.96 KB, text/plain)
2013-03-29 12:07 EDT, Ľuboš Kardoš
no flags Details
anaconda.log (7.25 KB, text/x-log)
2013-03-29 12:07 EDT, Ľuboš Kardoš
no flags Details
program.log (19.07 KB, text/x-log)
2013-03-29 12:07 EDT, Ľuboš Kardoš
no flags Details
storage.log (69.36 KB, text/x-log)
2013-03-29 12:08 EDT, Ľuboš Kardoš
no flags Details
packaging.log (339.77 KB, text/x-log)
2013-03-29 12:09 EDT, Ľuboš Kardoš
no flags Details

  None (edit)
Description Ľuboš Kardoš 2013-03-29 12:06:31 EDT
Description of problem:
Start installation in qemu-kvm with one disk. After anaconda starts, insert additional disk. In "MANUAL PARTITIONING" spoke click on "Reload storage configuration from disk." and then click on "Rescan Disks". After these steps there isn't new disk in "INSTALLATION DESTINATION" spoke.


Version-Release number of selected component (if applicable):
F19-Alpha-TC3
anaconda-19.14

How reproducible:
always

Steps to Reproduce:
1. Start installation in qemu-kvm with one disk. Use command: 
"qemu-kvm -vga std -monitor stdio -m 1024 -drive if=scsi,file=/tmp/disk1 -cdrom ~/iso_images/fedora/Fedora-19-Alpha-TC3-x86_64-DVD.iso -boot once=d -net nic,model=virtio -net tap"

2. Proceed to the "MANUAL PARTITIONING" spoke.

3. Click on "Reload storage configuration from disk." Now you can see message: "You can remove or insert additional disks at this time and press 'Rescan Disks' below for changes to take effect".

4. Put following command into qemu monitor:
"(qemu) pci_add auto storage file=/tmp/disk2,if=scsi"

5. Click on "Rescan Disks" and then click on "OK".

  
Actual results:
After clicking on "OK", you are redirected to "INSTALLATION DESTINATION" spoke. In this spoke you can see only one disk, newly inserted disk isn't here. When you switch to shell, command "ls /dev/sd*" prints: "/dev/sda /dev/sdb". You can also see that kernel recognized new inserted disk from output of dmesg.
  

Expected results:
Anaconda should recognize additionally inserted disk and show this disk in "INSTALLATION DESTINATION" spoke.

Additional info:
Comment 1 Ľuboš Kardoš 2013-03-29 12:07:05 EDT
Created attachment 718124 [details]
output of dmesg
Comment 2 Ľuboš Kardoš 2013-03-29 12:07:29 EDT
Created attachment 718125 [details]
anaconda.log
Comment 3 Ľuboš Kardoš 2013-03-29 12:07:58 EDT
Created attachment 718126 [details]
program.log
Comment 4 Ľuboš Kardoš 2013-03-29 12:08:32 EDT
Created attachment 718127 [details]
storage.log
Comment 5 Ľuboš Kardoš 2013-03-29 12:09:09 EDT
Created attachment 718128 [details]
packaging.log
Comment 6 Fedora Update System 2013-05-03 19:04:39 EDT
anaconda-19.24-1.fc19, python-blivet-0.12-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-blivet-0.12-1.fc19,anaconda-19.24-1.fc19
Comment 7 Fedora Update System 2013-05-04 14:50:56 EDT
Package anaconda-19.24-1.fc19, python-blivet-0.12-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.24-1.fc19 python-blivet-0.12-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7403/python-blivet-0.12-1.fc19,anaconda-19.24-1.fc19
then log in and leave karma (feedback).
Comment 8 Ľuboš Kardoš 2013-05-09 05:20:29 EDT
I retested this issue on anaconda 19.24-1 and the problem described in this bug is still present, moving to assigned.
Comment 9 Chris Lumens 2013-05-17 16:49:50 EDT
I'll take this back.  It looks like there's a lot of stuff going wrong here, but the bulk of it appears to be in anaconda.
Comment 10 Fedora Update System 2013-05-22 14:29:25 EDT
anaconda-19.30-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/anaconda-19.30-1.fc19
Comment 11 Fedora Update System 2013-05-22 18:39:10 EDT
Package anaconda-19.30-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-19.30-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8871/anaconda-19.30-1.fc19
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-05-24 16:18:13 EDT
anaconda-19.30-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.