Bug 929357 - resource leak: must call PK11_FreeSlot after SECMOD_CloseUserDB
Summary: resource leak: must call PK11_FreeSlot after SECMOD_CloseUserDB
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openldap
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Synacek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 929358
TreeView+ depends on / blocked
 
Reported: 2013-03-29 21:38 UTC by Rich Megginson
Modified: 2013-05-07 18:24 UTC (History)
5 users (show)

Fixed In Version: openldap-2.4.35-1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 929358 (view as bug list)
Environment:
Last Closed: 2013-04-03 07:00:50 UTC
Type: Bug


Attachments (Terms of Use)
patch to fix the problem (827 bytes, patch)
2013-03-29 21:38 UTC, Rich Megginson
no flags Details | Diff

Description Rich Megginson 2013-03-29 21:38:39 UTC
Created attachment 718176 [details]
patch to fix the problem

Description of problem:

NSS_ShutdownContext fails with SEC_ERROR_BUSY - resources in use.  This is because there is still a reference to the cert db opened with SECMOD_OpenUserDB.

Apps must call PK11_FreeSlot to release the reference after calling SECMOD_CloseUserDB - then NSS_ShutdownContext will return success.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Fedora Update System 2013-04-03 06:57:16 UTC
openldap-2.4.35-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/openldap-2.4.35-1.fc19

Comment 3 Fedora Update System 2013-04-03 07:12:44 UTC
openldap-2.4.35-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openldap-2.4.35-1.fc18

Comment 4 Fedora Update System 2013-04-15 09:24:56 UTC
openldap-2.4.35-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openldap-2.4.35-3.fc18

Comment 5 Fedora Update System 2013-04-20 19:26:48 UTC
openldap-2.4.35-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2013-05-07 18:24:08 UTC
openldap-2.4.35-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.