Bug 929384 - tboot update breaks grub2-mkconfig operation
Summary: tboot update breaks grub2-mkconfig operation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tboot
Version: 18
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gang Wei
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 946998 951871 955750 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-30 10:17 UTC by Neil Darlow
Modified: 2013-04-29 03:24 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-29 02:52:14 UTC
Type: Bug


Attachments (Terms of Use)
grub.cfg.new for failed grub2-mkconfig (5.25 KB, application/octet-stream)
2013-03-30 10:17 UTC, Neil Darlow
no flags Details

Description Neil Darlow 2013-03-30 10:17:27 UTC
Created attachment 718230 [details]
grub.cfg.new for failed grub2-mkconfig

Description of problem:
grub2-mkconfig bails-out with a syntax error following latest tboot update.

Version-Release number of selected component (if applicable):
tboot-1.7.3-2.fc18

How reproducible:
Every time.

Steps to Reproduce:
1. Update to tboot-1.7.3-2
2. Run grub2-mkconfig -o /boot/grub2/grub.cfg
3. Observe error messages
  
Actual results:
[neil@aspire ~]$ sudo grub2-mkconfig -o /boot/grub2/grub.cfg
[sudo] password for neil: 
Generating grub.cfg ...
Found theme: /boot/grub2/themes/system/theme.txt
Found linux image: /boot/vmlinuz-3.8.4-202.fc18.i686.PAE
Found initrd image: /boot/initramfs-3.8.4-202.fc18.i686.PAE.img
error: syntax error.
error: Incorrect command.
error: syntax error.
Syntax error at line 135
Syntax errors are detected in generated GRUB config file.
Ensure that there are no errors in /etc/default/grub
and /etc/grub.d/* files or please file a bug report with
/boot/grub2/grub.cfg.new file attached.done

Expected results:
No error s should be reported by this operation.

Additional info:
My hardware does not have tboot support.

Comment 1 David Cantrell 2013-04-01 19:41:57 UTC
*** Bug 946998 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2013-04-02 11:09:52 UTC
tboot-1.7.3-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/tboot-1.7.3-3.fc19

Comment 3 Fedora Update System 2013-04-02 11:13:46 UTC
tboot-1.7.3-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/tboot-1.7.3-3.fc18

Comment 4 Fedora Update System 2013-04-02 11:14:51 UTC
tboot-1.7.3-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/tboot-1.7.3-3.fc17

Comment 5 Fedora Update System 2013-04-02 19:17:31 UTC
Package tboot-1.7.3-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tboot-1.7.3-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-4653/tboot-1.7.3-3.fc19
then log in and leave karma (feedback).

Comment 6 Mads Kiilerich 2013-04-14 13:52:35 UTC
*** Bug 951871 has been marked as a duplicate of this bug. ***

Comment 7 Raj Upadhyaya 2013-04-14 14:21:08 UTC
Looks like the package tboot fix fixed it.

Since I am running Fedora 18, I installed

yum update --enablerepo=updates-testing tboot-1.7.3-3.fc18

Here is my output...
# grub2-mkconfig -o /tmp/grub.cfg
Generating grub.cfg ...
Found theme: /boot/grub2/themes/system/theme.txt
Found linux image: /boot/vmlinuz-3.9.0-rc6
Found initrd image: /boot/initramfs-3.9.0-rc6.img
Found linux image: /boot/vmlinuz-3.8.3-203.fc18.i686
Found initrd image: /boot/initramfs-3.8.3-203.fc18.i686.img
done

Comment 8 Samuele 2013-04-20 11:44:15 UTC
update decisive for me too!

Comment 9 Gang Wei 2013-04-28 05:01:50 UTC
*** Bug 955750 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2013-04-29 02:52:16 UTC
tboot-1.7.3-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-04-29 02:56:44 UTC
tboot-1.7.3-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-04-29 03:24:47 UTC
tboot-1.7.3-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.