Bug 9306 - Reset on /dev/lp0
Reset on /dev/lp0
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: dev (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-10 10:27 EST by Giovanni
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-29 08:49:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giovanni 2000-02-10 10:27:44 EST
I have installed Red Hat 6.1. Configured my parallel port and attached a
printer (Lexmark 2381 Plus).
The default settings of the printer is : 10 Cpi and 11'' Form Lenght.
If I change without saving the default settins (for ex. 17 Cpi and 12'' FL)
and start to print all is OK but if I wait for about 20 minutes and i
retray to print, the printer reset to the default settings and then start
to print.
I have tray to print directly to /dev/lp0 and I have the same problem.
I have notice that when I start Red Hat 6.1 and I print for the first time
the printer before to print execute a reset (only on the first print).
It seems that the device /dev/lp0 reset the first time that is used and
then about every 20 minutes if is not used.
Comment 1 Nalin Dahyabhai 2000-02-10 14:47:59 EST
If your parallel port is being reset, it could be because the driver module that
is being loaded when you access the printer is being unloaded, and it appears to
be resetting when you try to access the parallel port again.

To disable the reset when the module is first loaded, add the line
options lp reset=0
to /etc/conf.modules and run "depmod -a" to regenerate the dependencies for your
kernel modules.

The removal of the kernel module is caused by a cron job (set up in
/etc/cron.d/kmod) which executes every 10 minutes.  Another fix would be to
just remove this file.

Please let me know if this solves the problem.
Comment 2 Giovanni 2000-02-11 10:47:59 EST
Thanlk You for your help.
I have solved in part my problem.
I have modified the file /etc/conf.modules:
            alias parport_lowlevel parport_pc
            options lp reset=0
Then I have executed the command:
            depmod -a
Finally I have removed the file:
            /etc/cron.d/kmod
I have rebooted my Red Hat 6.1.
Now if I change the default setting of my printer (without saving) and I
print also after 20 minutes
my printer holds the momentary settings (and this is a good thing for
me).
But the problem  remain  only when I start to  print for the first time.
When I boot Linux and I print
for the first time, the printer execute  a  reset and then start to
print. After this print the other jobs
are executed correctly without any  reset.
I heve Red Hat 6.1 without any patch installed.

Thanl You very much.
Giovanni.
Comment 3 Nalin Dahyabhai 2000-02-29 08:49:59 EST
If you have reset=0 set in your /etc/modules.conf file, and are only loading the
parallel port driver as a module, then I suspect your BIOS is resetting the port
at boot-time, before the kernel even begins executing.  Unfortunately, there's
nothing I can do about that.
Comment 4 Nalin Dahyabhai 2000-07-10 17:29:06 EDT
I guess that solved the problems that were solvable in software.

Note You need to log in before you can comment on or make changes to this bug.