Bug 9310 - " #! /usr/bin/perl " FAILS (take any interpreter for the perl location)
" #! /usr/bin/perl " FAILS (take any interpreter for the perl location)
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: basesystem (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-10 12:01 EST by hyperbyte
Modified: 2014-03-16 22:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-16 10:08:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hyperbyte 2000-02-10 12:01:41 EST
HI,
I'm a newbie to linux, and so I may perhaps make a stupid mistake, but...

I read that if I add "#! /usr/bin/perl" to the top of a perl script (or
any script if it just points to the script interpreter), and if I "chmod
+x" it, that it will be executable, and will automatically run the perl
interpreter if i execute it.

It does not work, and I think it is fairly important. I already checked if
it points to the perl-path, and the scripts work if i do "perl [script]"

but when I just execute the script i get "command not found" or something
like that.

PLEASE help me!

Thanx in advance,
Peter Martijn Kuipers
Comment 1 Bill Nottingham 2000-02-10 14:36:59 EST
I can't reproduce this here; perl scripts seem to run OK.

What does rpm -V perl say?
Comment 2 Bruce Wayne 2000-02-14 13:50:59 EST
Is the "#!/usr/bin/perl" line the very first line of your file.
It must be the first line.

Note You need to log in before you can comment on or make changes to this bug.