This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 9313 - valloc() is broken in glibc-2.1.3: returns are not aligned
Summary: valloc() is broken in glibc-2.1.3: returns are not aligned
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-10 17:51 UTC by Stephen Tweedie
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
regression test for valloc() in glibc. (299 bytes, text/plain)
2000-02-10 17:52 UTC, Stephen Tweedie
no flags Details

Description Stephen Tweedie 2000-02-10 17:51:08 UTC
valloc() is a variant of malloc() intended to return page-aligned
memory areas.  It is relied on by certain programs for mmap() alignment
or for raw IO, in which cases the kernel enforces page alignment on the
user's buffers.

RH6.1 valloc() correctly aligns its return addresses.  This is no longer
true in RH6.2 beta, and code may break because of this.  In particular,
lmdd running on raw devices is now broken in 6.2 due to this problem.

I'll attach a trivial test program demonstrating the bug.

Comment 1 Stephen Tweedie 2000-02-10 17:52:59 UTC
Created attachment 110 [details]
regression test for valloc() in glibc.

Comment 2 Stephen Tweedie 2000-02-23 17:11:59 UTC
Confirmed fixed in glibc-2.1.3-10.


Note You need to log in before you can comment on or make changes to this bug.