Bug 9320 - Font path problem, possibly causing Netscape crashes
Summary: Font path problem, possibly causing Netscape crashes
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: chkfontpath   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-10 21:30 UTC by Brian Ryner
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-24 03:42:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian Ryner 2000-02-10 21:30:48 UTC
I noticed that Netscape seemed to be crashing on pages with Java applets.
I seem to remember this being an issue awhile back, and the solution was to
make sure /usr/X11R6/lib/X11/fonts/75dpi (without the :unscaled) was in the
font path.  I checked my font path now, and sure enough, that entry wasn't
in the list, just the unscaled version.  I tried to add it myself by
running:

/usr/sbin/chkfontpath --add /usr/X11R6/lib/X11/fonts/75dpi

but it said:

chkfontpath: /usr/X11R6/lib/X11/fonts/75dpi already in list

This seems like a bug in chkfontpath to me; if, on the other hand, having
the font directory without the :unscaled should no longer be necessary,
then the problem must be somewhere else (perhaps in xfs).

Comment 1 Preston Brown 2000-02-24 03:42:59 UTC
this was due to a bad default xfs config file.  modified in latest XFree86
3.3.6-15 to work well with new chkfontpath.


Note You need to log in before you can comment on or make changes to this bug.