Bug 9365 - systat/netstat entries in inetd.conf
systat/netstat entries in inetd.conf
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: inetd (Show other bugs)
6.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-11 15:58 EST by Randy Russell
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-27 07:00:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Russell 2000-02-11 15:58:14 EST
(Note: this misconfiguration is also present in 6.1 and probably numerous
earlier versions, but is of pretty trivial importance.  We might want to
make the fix for 6.2, however.)

The entries for the systat and netstat services in /etc/inetd.conf are
commented by default, which is appropriate.  Should someone choose to
uncomment those services, then HUP or otherwise restart inetd, they would
find that they could successfully connect to those services, but that the
services themselves would not execute properly.  All that would happen is
the connection followed by immediate disconnection.

The reason they seem to fail is that /etc/inetd.conf specifies that the
associated commands are to be run by the user "guest".  Because that user
does not exist, the command is not executed.  Substituting some other
unprivileged user, such as "nobody", will allow those services to perform
as expected.

Given that the services are commented out, that people seldom use these
"services", and often sys admins choose not to run ANY inetd services, this
is a very low priority bug.  Nevertheless, it is one we might wish to
change for 6.2 so that things work correctly -- even services that we might
have little enthusiasm for people running.
Comment 1 Pekka Savola 2000-07-16 12:57:00 EDT
Not an issue anymore.

Note You need to log in before you can comment on or make changes to this bug.