Bug 9386 - Gnome-terminal crashes with sawmill wm
Summary: Gnome-terminal crashes with sawmill wm
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sawmill (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-12 23:23 UTC by Roy W. Andersen
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-15 20:56:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Roy W. Andersen 2000-02-12 23:23:57 UTC
When you run the gnome-terminal while using the Sawmill wm,
gnome-terminal exits with this error:

 Gdk-ERROR **: BadDrawable (Invalid Pixmap or Window parameter)
   serial 516 error_code 9 request_code 14 minor_code 0

Comment 1 Preston Brown 2000-02-15 17:06:59 UTC
I'm running sawmill and plenty of gnome-terminals, and I don't see this
problem.  Are you doing anything else out of the ordinary?  Does it crash every
time you try and run it?  If not, how do you trigger the crash?

Comment 2 Roy W. Andersen 2000-02-15 17:19:59 UTC
Strangely enough, it doesn't happen anymore. The only thing
I've done since I tried it last is install a new kernel (compiled
from source) and rebooted. I haven't done anything with neither
GNOME nor Sawmill. But when it happened it happened every time
and without me doing anything else than start the gnome-terminal
program.

Comment 3 Owen Taylor 2000-02-15 19:02:59 UTC
The problem is most likely that a background pixmap property was
set by enlightenment; this stale property confused the gnome-terminal
transparent-background code causing the crash. Rebooting fixed the
problem since enlightenment was no longer there to set the background.
Working on a patch now.

Comment 4 Owen Taylor 2000-02-15 20:56:59 UTC
Should be fixed in gnome-libs-1.0.55-10


Note You need to log in before you can comment on or make changes to this bug.