Bug 9390 - X server hangs, then crashes
X server hangs, then crashes
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-12 21:23 EST by Jonathan Kamens
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-14 11:28:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my XF86Config file (15.31 KB, text/plain)
2000-02-12 21:23 EST, Jonathan Kamens
no flags Details

  None (edit)
Description Jonathan Kamens 2000-02-12 21:23:06 EST
I'm running XFree86-Mach64.  I will attach my XF86Config file.

Twice in the last few days, my X server has hung while xfishtank was
running inside xscreensaver (xfishtank-2.1tp-1, xscreensaver-3.23-1).  The
second time, I logged in remotely and killed xfishtank, at which point the
screen went blank, and then xscreensaver.  Nothing happeneds, so I switched
to virtual terminal 1 and then back to 7 (where the X server was running).
At this point, my X server crashed.  Here's as much of the output at the
end of my console scroll buffer as I was able to capture:

(--) Mach64: Clock type: Internal
(--) Mach64: Maximum allowed dot-clock: 230.000 MHz
(**) Mach64: Mode "1280x1024": mode clock =  80.000
(--) Mach64: Virtual resolution: 1280x1024
(**) Mach64: Video RAM: 8192k
(--) Mach64: Using hardware cursor
(--) Mach64: Using 16 MB aperture @ 0xfd000000
(--) Mach64: Using 4 KB register aperture @ 0xfe6ff000
(--) Mach64: Ramdac is Internal
(--) Mach64: Ramdac speed: 230 MHz
(**) Mach64: Color weight: 565
(--) Mach64: Pixmap cache: 2 256x256 slots, 8 128x128 slots, 32 64x64 slots
(--) Mach64: Font cache: 16 fonts
Feb 11 15:57:41 jik /sbin/slip.exp[1186]: PID is 1186.
SetKbdSettings - type: 2 rate: 30 delay: 500 snumlk: 0
SetKbdSettings - Succeeded
Feb 11 15:57:43 jik /sbin/slip.exp[1186]: Dialing 867-4900.
mach64ProgramClkMach64CT: Warning: Q < 10.66666667


Caught signal 11.

Server aborting...
mach64ProgramClkMach64CT: Warning: Q < 10.66666667

eip: 080a904a   eflags: 00013213
eax: 0206ae20   ebx: 082c2d30   ecx: 082c2d30   edx: 40128638
esi: 00000001   edi: 00000000   ebp: bffff650   esp: bffff638
Stack: 082c2d30 00000001 00000002 08243d4c 00000000 bffff670 bffff670
0809e2a1
       082c2d30 00000008 0000000d 082c2d30 00000000 00000000 bffff718
080b98ae
       082c2d30 08269af0 08243d50 00000000 0000000d 00000002 48bbbb78
00000000
       00000002 00000000 00000000 00000000 00000000 00000000 00000000
00000000
Call Trace: 0809e2a1 080b98ae 080bd3a5 0809f211 080b733f 08098d55 0807ab89
       0807ebcf 080a8152 080a15c3 08098d08 080a7d75 0806c3e0 0806c401
080a7930
       081db55c 0806c3e0
Code: 8b 88 40 41 24 08 89 4d fc 3b b8 48 41 24 08 7d 77 90 8d 74

Please forward information about this crash to XFree86@XFree86.org
including the _full_ output of the X server.

To analyse the crash dump, please type

        gdb /etc/X11/X /b/home/jik/core
        where

and include this output in your report.  Thanks!

xinit:  connection to X server lost.

I was *not* able to get a stack trace, because apparently one of the xterms
running inside the X server crashed right after the server did and
overwrote the server's core file.
Comment 1 Jonathan Kamens 2000-02-12 21:23:59 EST
Created attachment 114 [details]
my XF86Config file
Comment 2 Jonathan Kamens 2000-02-13 18:41:59 EST
I almost certainly should have mentioned that I believe that each time my X
server hung, I had previously shut down and restarted the X font server.
Comment 3 Preston Brown 2000-02-14 11:28:59 EST
Shutting down and restarting the X server while X is running can have
unpredictable results.  Don't do that.

Note You need to log in before you can comment on or make changes to this bug.