Bug 9392 - dropped serial bits|bytes
Summary: dropped serial bits|bytes
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-13 05:25 UTC by wb8foz
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-16 02:52:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description wb8foz 2000-02-13 05:25:11 UTC
Tomcat III
I have 2 mb serial ports, as well as two AST 4-port cards. These often
monitor router console screens; i.e. VT100 emulation w/miniterm.

All the ports have, over time, dropped a bit|byte here & there, as seen
by scrambled screen displays. A ^L-stype screen repaint clears same.

But with 6.1, the problem is visibly worse -- now, in only 15 minutes
or so, the display is a real mess. This seems true more on the 4-ports
than the 2 integral ports, but still ttyS0|1 are worse than in the past.

I checked with Ted Tso & he had no immediate answers.

Comment 1 Jeff Johnson 2000-07-27 20:51:30 UTC
This is a kernel driver problem ...

Comment 2 Alan Cox 2000-08-08 19:35:56 UTC
Does hdparm -u1 /dev/hda fix this
[See man hdparm first]


Comment 3 wb8foz 2000-08-19 02:13:52 UTC
Fog lifts slightly. Looks like 6.1 upgrade (now 2.2.12-20) put IDE drives in PIO
mode. That likely explains why it got so much worse at that time. 

But note the problem exist[s,ed] (to a far lesser extent) even without being
dumped in PIO. Would think 16550A's & 950's had enough buffer.



Comment 4 Alan Cox 2000-09-15 18:22:28 UTC
Im suprised you see it with -u1. What other drivers are on your box.

Comment 5 Alan Cox 2002-12-16 02:52:11 UTC
Ancient release, no reply



Note You need to log in before you can comment on or make changes to this bug.