Bug 9411 - Macro Problem in rpm-3.0.3-5x RPM
Summary: Macro Problem in rpm-3.0.3-5x RPM
Status: CLOSED DUPLICATE of bug 14271
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 5.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-13 23:59 UTC by Thomas Ribbrock
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-03 22:00:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Ribbrock 2000-02-13 23:59:42 UTC
After upgrading from rpm-3.0.2-5.x (RHL 5.2 updates) to rpm-3.0.3-5x (as
provided on rpm.org), rpm building fails with a chown error. Example:

[root@esme SPECS]# rpm -bp mutt.spec
Executing: %prep
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd /usr/src/redhat/BUILD
+ rm -rf mutt-1.0.1
+ /bin/gzip -dc /usr/src/redhat/SOURCES/mutt-1.0.1i.tar.gz
[...]
+ STATUS=0
+ [ 0 -ne 0 ]
+ cd mutt-1.0.1
++ /usr/bin/id -u
+ [ 0 = 0 ]
+ /bin/chown -Rhf root .
/bin/chown: --no-dereference (-h) is not supported on this system
Bad exit status from /var/tmp/rpm-tmp.67297 (%prep)

Indeed, chown doesn't support -h on this RHL 5.2 system (all upgrades
applied).

[root@esme SPECS]# rpm -qf /bin/chown
fileutils-3.16-10

I tracked this down to a change in /usr/lib/rpm/macros:
%_fixowner              [ `%{__id} -u` = '0' ] && %{__chown} -Rhf root

In the 3.0.2-5.x RPM, this used to be:
%_fixowner              [ `%{__id} -u` = '0' ] && %{__chown} -Rf root

The same problem occurs with regard to chgrp, i.e. error message
complaining about the -h flag.

Workaround: Setting both macros to their old values in /etc/rpm/macros
Fix (I suppose): Changing /usr/lib/rpm/macros in the RPM to the old values.

Regards,

Thomas

Comment 1 Thomas Ribbrock 2000-04-03 22:00:59 UTC
Update: This problem is still present in the 3.0.4-5x RPMs.

Comment 2 Jeff Johnson 2000-07-21 14:01:03 UTC

*** This bug has been marked as a duplicate of 14271 ***


Note You need to log in before you can comment on or make changes to this bug.