Bug 9412 - Didn't detect mouse
Didn't detect mouse
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-13 19:27 EST by Jonathan Gardner
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-23 16:33:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Gardner 2000-02-13 19:27:03 EST
During the install my mouse was completely useless. I was able to install
RH 6.2 beta but it was not easy without mouse support in the GUI install.
For the most part tab and Enter did the trick, but I couldn't expand
certain trees so it meant tweaking things after the install was complete.
Comment 1 Jay Turner 2000-02-14 07:45:59 EST
What type of mouse were you using?  What did you select in the mouse config
screen during the installation?
Comment 2 Jonathan Gardner 2000-02-16 15:22:59 EST
I should have added, I'm using a microsoft wheel mouse on ttyS0.
Comment 3 Jonathan Gardner 2000-02-16 15:25:59 EST
I chose generic 3 button mouse during install, because I couldn't expand the
microsoft tree. I tried once running it with a truly generic mouse, but still no
luck.
Comment 4 Jay Turner 2000-02-22 16:51:59 EST
You are selecting a serial mouse and picking the appropriate port correct?  I
have no trouble running the installer with this mouse.
Comment 5 Jonathan Gardner 2000-02-22 20:02:59 EST
Yes, and it has no problem running once the install is finished, but the mouse
does not work during the install, making it impossible to expand certain trees
and select certain items. Also using tab and enter can be a bit of a pain.
This mouse problem is right from the very beginning even before I can select a
mouse and ends when X starts.
The mouse works fine, if not the wheel because I had to manually fix that, once
gdm takes over. It's during the anaconda install that the mouse doesn't work.
Comment 6 Jay Turner 2000-02-23 16:33:59 EST
If this is an IntelliMouse, then this is the problem.  The IntelliMouse using a
different protocol for X, so you would need to select the appropriate entry in
the Microsoft tree.  The trees can be expanded using the "+" key and collapsed
using the "-" key.

Please reopen if you continue to have problems.

Note You need to log in before you can comment on or make changes to this bug.