Bug 9415 - Macros get expanded within comments in rpm 3.0.3
Summary: Macros get expanded within comments in rpm 3.0.3
Status: CLOSED DUPLICATE of bug 5364
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 5.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-14 01:05 UTC by Thomas Ribbrock
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-21 10:44:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Ribbrock 2000-02-14 01:05:39 UTC
rpm 3.0.3 seems to expand macros within comments. Example:

Having the following two lines

# User-Defined Macros:
# %define <name> <expansion>

in a spec file will lead to an error message:
"Macro % has illegal name (%define)"

This was working ok in rpm 3.0 and 3.0.2.

Regards,

Thomas

Comment 1 Jeff Johnson 2000-02-21 10:44:59 UTC
*** This bug has been marked as a duplicate of 5364 ***


Note You need to log in before you can comment on or make changes to this bug.