Bug 9416 - initscripts RPM requires which to be installed
initscripts RPM requires which to be installed
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Depends On:
  Show dependency treegraph
Reported: 2000-02-14 02:02 EST by Steve Muir
Modified: 2014-03-16 22:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-02-14 09:07:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Steve Muir 2000-02-14 02:02:10 EST
The prefdm script installed as part of initscripts calls `which' to
determine which X display manager to run.  If `which' is not installed
then prefdm just exits with code 1, which causes it to be continually

Either prefdm should not use which e.g., use type -path instead, or
the initscripts RPM should have which as a dependency.
Comment 1 Nalin Dahyabhai 2000-02-14 09:07:59 EST
Thanks for the heads-up.  This will be fixed in initscripts-4.93-2 and later in
Raw Hide.

Note You need to log in before you can comment on or make changes to this bug.