Bug 9419 - Wrong DEVICE parameter to /sbin/ifup-local for PPP interfaces
Summary: Wrong DEVICE parameter to /sbin/ifup-local for PPP interfaces
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-14 09:29 UTC by Alexander V. Konstantinou
Modified: 2014-03-17 02:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-28 16:31:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexander V. Konstantinou 2000-02-14 09:29:19 UTC
The /etc/ppp/ip-up script does not set the DEVICE environment variable
before invoking

/etc/sysconfig/network-scripts/ifup-post ifcfg-${LOGDEVICE}

for a PPP connection.  Since the ifcfg-* file does not exist for ppp
devices, the ifup-post does not pass the correct device name to the
ifup-local script.  In fact, it passes the PPP device name (e.g.
/dev/modem) instead of "ppp0".

Solutions (several possible) :

1. Add the following line to /etc/ppp/ip-up before invoking ifup-post :

export DEVICE=$REALDEVICE

2. Modify ifup-post to check if the ifcfg-${LOGDEVICE} file exists, and
  if not, set the DEVICE variable to the logdevice specified in the
  filename

Comment 1 Bill Nottingham 2000-02-28 16:31:59 UTC
? The ifcfg-ppp<whatever> files certainly should exist in
the normal cases.


Note You need to log in before you can comment on or make changes to this bug.