Bug 942 - Sndcnfig: libnewt dependency, CMI8330 status
Sndcnfig: libnewt dependency, CMI8330 status
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-24 13:44 EST by donn
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-03 18:24:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description donn 1999-01-24 13:44:30 EST
1)  sndconfig needs (at least when I downloaded it last
    weekend) a new version of libnewt (0.40).  (I'll
    be honest; this COULD have been fixed since, but I
    haven't looked).  That version of libnewt won't run
    because of an unsatisfied reference to __bzero.
    (With the underbars!).
    I suspect that it's an unintended dependency due to
    a new compiler or new option: I downloaded the sources
    and compiles up and runs just fine.

    When it doesn't run, it's gotten far enough to put the
    tty into raw mode.  (Easy enough to fix, but...)

2)  The new sndconfig does recognize the CMI8830 and its
    clone the HT1869V+ (which is what's on my motherboard).
    However, due to strangenesses in my configuration,
    the defaults don't work (they don't work on DOS,
    either).  (It's an IRQ conflict with an IRQ level
    that no hardware claims: maybe a motherboard problem.)

    Bug:
    isapnp DOES detect the conflict and reports it when
    run by hand.  However, the output from isapnp is not
    reported by sndconfig.  In this case, it gets far
    enough that the test of playing a .wav file works,
    but (e.g.) synaesthesia doen't work because of
    interrupt problems (which the soundblaster module
    also reports).
    So... (1) sndconfig should report isapnp's errors.
    (2) it should report modprobe's errors.

    (It appears that things are such that sndprobe makes
    things sort-of work in the same boot lifetime that it
    is run in, but until everything is right, sound doesn't
    work after a reboot.  --- Now that I've gotten the
    interrupts untangled everything works fine for me.)

3)  The soundblaster driver works fine with the chip, but
    the setup seems strange: I was never able to get it
    to work at IO 0x220, which is the default for the
    DOS drivers for this chip (as far as I can tell from the
    vague statements in the associated documentation).
    I have it set up at 0x530 and that's fine.  (There
    may be a luck factor here.)  (The chip as both SB and
    WSS ports, and the DOS setup "wants" the WSS at 0x530
    and the SB at 0x220).

4)  The chip supports S/PDIF, but I was unable to find
    anywhere any drivers that support it.  Since the only
    channel from the CD to the sound board is via the
    S/PDIF channel, I needed it.  I ended up hacking
    dspcntrl (from the web) to do the job, but consider this
    an enhancement request to the sound drivers and mixers
    to support controlling that bit.  (Ditto the loudness
    and 3D bits.)

I'm submitting a separate bug w.r.t. isapnp at boot time,
that's a bit tangled with this.
Comment 1 Bill Nottingham 1999-01-25 12:12:59 EST
1) is due to glibc2.1.
2) sndconfig does print isapnp errors, but only if isapnp
exits non-zero. If it exits with a status of zero, it assumes
it succeeded.
3) Using 0x530 for the sb driver shouldn't work (it doesn't
on the CMI8330 we have here), as that's the
WSS emulation. You could try using 0x240.
4) is a driver issue; we don't maintain the drivers, per se.
Comment 2 David Lawrence 1999-03-03 18:24:59 EST
Thank you for the suggestions. We have noted them and will work on
getting them into the next release.

Note You need to log in before you can comment on or make changes to this bug.