Bug 9456 - NFS mount fails if the server is rebooted
Summary: NFS mount fails if the server is rebooted
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-15 09:16 UTC by Luca Bonomi
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-28 15:21:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Luca Bonomi 2000-02-15 09:16:59 UTC
A mounted NFS filesystem cannot be accessed (permission denied) when the
server is back online after a reboot (crash).

To reproduce the error:

- NFS mount a filesystem
- 'ls <filesystem>' to check it works
- Reboot the server
- 'ls <filesystem>' hangs (correct behaviour) when the server is off and
returns 'permission denied' (wrong behaviour) after the server has become
online.

This is seen no matter you are using 'hard' or 'soft' option for the NFS
mount.

Note that the behaviour is NOT normal. Reading from 'man mount' in the
section 'Mount options for nfs', option 'hard' you get in fact:

"When  the NFS server is back online the program will continue undisturbed
from where it was."

Indeed this is what should happen, since NFS is a stateless protocol.

Comment 1 Bernhard Rosenkraenzer 2000-02-15 14:11:59 UTC
Works for me... What kernel are you running?

Comment 2 Riley H Williams 2000-02-15 18:25:59 UTC
I've met this on one occasion only. When it occurred, I discovered that the
server grabbed its IP address via BOOTP and had been given a different IP
address when it rebooted after crashing.

I would imagine a similar problem would occur if one was accessing the NFS
server through a masquerading firewall with a Dynamic IP link out.


Note You need to log in before you can comment on or make changes to this bug.