Bug 946915 - can't start openstack-keystone
can't start openstack-keystone
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: openstack-packstack (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Magr
Fedora Extras Quality Assurance
:
: 946887 981587 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-31 19:07 EDT by Derek Higgins
Modified: 2015-06-29 21:31 EDT (History)
19 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.1.1-0.4.dev538
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-29 21:31:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Derek Higgins 2013-03-31 19:07:32 EDT
keystone is failing to start, as it can't write to the keystone log file
# ls -l /var/log/keystone/
total 0
-rw-r--r--. 1 root root 0 Mar 31 22:54 keystone.log


I'm guessing the file was created with keystone-manage db_sync was run

openstack-keystone-2013.1-0.9.rc2.fc19.noarch

using grizzly side repo
http://repos.fedorapeople.org/repos/openstack/openstack-grizzly/fedora-18/
Comment 1 Pádraig Brady 2013-03-31 21:27:07 EDT
What's running keystone-manage as root?

openstack-db --init for example does:

APP=keystone
runuser -s /bin/sh $APP -c "$APP-manage $db_sync"
Comment 2 Derek Higgins 2013-04-01 05:05:07 EDT
the packstack and the puppet modules both use keystone-manage, has something changed this always worked upto now?
Comment 3 Pádraig Brady 2013-04-01 23:22:00 EDT
If the puppet modules run keystone-manage as root then I don't know how it worked as nothing has changed recently in this regard?
Comment 4 Jiri Stransky 2013-04-04 05:39:29 EDT
I hit this issue too (on RHEL 6.4) and so did Thomas Oulevey from Cern. More info on rhos-list:

https://www.redhat.com/archives/rhos-list/2013-April/msg00007.html
Comment 5 Derek Higgins 2013-04-04 06:15:58 EDT
by the looks of it this is being cause by a change in keystone-manage,
specifically this commit
https://github.com/openstack/keystone/commit/a198f59df7063424dcf682430d24ba67dc562b79

keystone-manage didn't used to create the keystone.log file but now it does

I submitted a update to packstack
https://review.openstack.org/#/c/26075/
Comment 6 Alan Pevec 2013-04-07 19:08:51 EDT
(In reply to comment #5)
> I submitted a update to packstack
> https://review.openstack.org/#/c/26075/

Is there a build with that?
Comment 7 Justin Clift 2013-04-08 15:34:35 EDT
*** Bug 946887 has been marked as a duplicate of this bug. ***
Comment 8 Martin Magr 2013-04-09 07:03:10 EDT
Not yet, will create the build today.
Comment 9 Alan Pevec 2013-04-10 14:13:22 EDT
FYI from dprince
> fixed this issue in the upstream keystone puppet modules here:
> 
>   https://github.com/stackforge/puppet-keystone/commit/7adce5be3bf18e8074cc6ea3921b7e7e13ccd444
Comment 10 Martin Magr 2013-07-08 06:01:48 EDT
*** Bug 981587 has been marked as a duplicate of this bug. ***
Comment 11 Fedora End Of Life 2013-09-16 12:56:48 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 20 development cycle.
Changing version to '20'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora20
Comment 12 Fedora Admin XMLRPC Client 2013-10-14 05:50:21 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 13 Fedora Admin XMLRPC Client 2013-10-14 05:50:50 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 15 Gabriele Cerami 2014-03-25 09:33:43 EDT
Hit this bug again on

Version     : 2014.1.1
Release     : 0.4.dev1018.fc21

during  a --allinone install on Fedora 20.
Same symptoms.
Comment 16 Pádraig Brady 2014-03-25 09:34:02 EDT
Bug #1080438 might also be related as it is also intermittent and related to something in puppet land setting root permissions sometimes
Comment 17 Fedora End Of Life 2015-05-29 04:58:00 EDT
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 18 Fedora End Of Life 2015-06-29 21:31:02 EDT
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.