Bug 947137 - python-blivet cannot require hfsplus-tools on arm because of dependency issues on that platform
python-blivet cannot require hfsplus-tools on arm because of dependency issue...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2013-04-01 13:56 EDT by Dennis Gilmore
Modified: 2013-04-19 10:01 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-blivet-0.10-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-19 10:01:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to make archful and require hfsplus-tools only where its needed (672 bytes, patch)
2013-04-01 13:56 EDT, Dennis Gilmore
no flags Details | Diff

  None (edit)
Description Dennis Gilmore 2013-04-01 13:56:03 EDT
Created attachment 730367 [details]
patch to make archful and require hfsplus-tools only where its needed

Description of problem:
python-blivet has a Requires on hfsplus-tools which needs to be architecture specific as well as other sections of architecture specific requires, none of the architecture specificness can work for a noarch package.

the reason that hfsplus-tools needs to be arch specific is due to clang which is used to build it being completely broken on arm,  it does needs fixing but it is only needed on x86_64 for mactel support.

im attaching a patch to make things as they should be.
Comment 1 David Lehman 2013-04-01 14:15:16 EDT
I'm not inclined to change the package from noarch to arch-specific because some package won't build on arm.

At some point I am planning to make many of the python-blivet requires soft by removing them from the specfile and adding code to gracefully handle the possibility of those packages/tools being absent at runtime. At this point there are many more pressing issues.

For now, the fix is to fix that package that won't build on arm.
Comment 2 Dennis Gilmore 2013-04-01 15:02:33 EDT
you already have arch specific Requires wrapped in %ifarch in the spec file that will only work if the packages is archful either than needs removed or the .  The fix to make hfsplus-tools build on arm is massive amounts of work in llvm and clang. the package is only needed for mactel, the right fix is to make the package archful not just for teh arm issue but for the currently broken logic in the spec file.
Comment 3 Jon Masters 2013-04-01 15:18:23 EDT
Let me chime in here. David, I understand your concerns, and ordinarily I would agree with you. However, I disagree here because the package concerned is an entire alternate toolchain that is not really supported in Fedora as it stands. LLVM is supported for use by llvmpipe (its use case) but the tools team does not support it (other than occasional best efforts) and its level of function is subsequently not guaranteed even on x86. Therefore, it is in the best interest of Fedora not to grow further dependencies upon LLVM, especially in critical pieces of infrastructure for the project, such as Anaconda.
Comment 5 David Lehman 2013-04-03 12:47:38 EDT
I am in the process now of moving the requires for the following packages to anaconda, since python-blivet does not strictly require them:

 iscsi-initiator-utils
 fcoe-utils
 dmidecode
 hfsplus-tools

The hfsplus-tools package will only be required on x86 platforms.
Comment 6 Peter Robinson 2013-04-05 20:05:53 EDT
Ultimately while there might be a certain amount of interesting in supporting  hfsplus-tools on all platforms for corner cases the only platform it's really useful on is x86-64 to support Apple devices for dual boot. Similarly dmidecode is very platform dependent. the others should, at least in theory, be supportable on all platforms even if it's the software stacks.
Comment 7 David Lehman 2013-04-19 10:01:57 EDT
This was fixed in python-blivet-0.10-1.

Note You need to log in before you can comment on or make changes to this bug.