Bug 947261 - AttributeError: 'module' object has no attribute 'memInstalled' (anaconda fails to boot with 512mb ram in TEXT MODE)
Summary: AttributeError: 'module' object has no attribute 'memInstalled' (anaconda fai...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
Depends On:
Blocks: F19Alpha-accepted, F19AlphaFreezeException
TreeView+ depends on / blocked
 
Reported: 2013-04-02 00:36 UTC by Reartes Guillermo
Modified: 2013-04-30 18:45 UTC (History)
9 users (show)

Fixed In Version: anaconda-19.17-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-30 18:45:07 UTC


Attachments (Terms of Use)
screen-shot of the crash in text mode with 512mb (not in the logs) (27.16 KB, image/png)
2013-04-02 00:36 UTC, Reartes Guillermo
no flags Details
anaconda.log (323 bytes, text/plain)
2013-04-02 00:37 UTC, Reartes Guillermo
no flags Details
program.log (829 bytes, text/plain)
2013-04-02 00:37 UTC, Reartes Guillermo
no flags Details
storage.log (2.82 KB, text/plain)
2013-04-02 00:37 UTC, Reartes Guillermo
no flags Details
syslog file (68.48 KB, text/plain)
2013-04-02 00:38 UTC, Reartes Guillermo
no flags Details

Description Reartes Guillermo 2013-04-02 00:36:11 UTC
Created attachment 730527 [details]
screen-shot of the crash in text mode with 512mb (not in the logs)

Description of problem:

When having a system (KVM Guest in this case) with only 512mb ram, booting with the 'text' boot parameter fails.

Version-Release number of selected component (if applicable):
F19a TC3

How reproducible:
always

Steps to Reproduce:
1. Set the guest to have 512mb RAM
2. boot and add the kernel boot parameter: 'text'
3. anaconda will not start, printing an error (but no anaconda-tb-XXX file)
  
Actual results:
cannot install in text mode with 512mb ram

Expected results:
working text mode

Additional info:

Comment 1 Reartes Guillermo 2013-04-02 00:37:12 UTC
Created attachment 730528 [details]
anaconda.log

Comment 2 Reartes Guillermo 2013-04-02 00:37:31 UTC
Created attachment 730529 [details]
program.log

Comment 3 Reartes Guillermo 2013-04-02 00:37:52 UTC
Created attachment 730530 [details]
storage.log

Comment 4 Reartes Guillermo 2013-04-02 00:38:19 UTC
Created attachment 730531 [details]
syslog file

Comment 5 Adam Williamson 2013-04-03 16:56:07 UTC
This happens if you boot graphical mode with 512MB of RAM too. Booting either graphical or text with 768MB of RAM succeeds.

Note the screenshot: The problem is in a check for sufficient RAM for VNC, not in the installer's own check for minimum sufficient RAM. So this is actually blocking text installs with 512MB of RAM (a 'supported' configuration) as things stand.

Discussed at 2013-04-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-04-03/f19alpha-blocker-review-4.2013-04-03-16.01.log.txt . Rejected as a blocker: there's clearly a bug here, but all you're going to get if we fix it is a better error message (graphical) or a later failure (text). It doesn't hit any of the release criteria.

We might be open to FE status for this one if the installer team comes up with a fix and thinks it's worth applying. It's more likely to be counted FE if a 512MB text install actually succeeds once this is fixed - otherwise, this error is really just saving people time...

Comment 6 Adam Williamson 2013-04-05 19:13:55 UTC
I'm going to take the commit of a fix for this as an implied FE request from the anaconda team.

Comment 7 Adam Williamson 2013-04-08 16:32:24 UTC
Discussed at 2013-04-08 freeze exception review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-04-08/f19alpha-blocker-review-5.2013-04-08-16.01.log.txt . Accepted as a freeze exception for the benefit of potentially fixing 512MB text installs.

Comment 8 Fedora Update System 2013-04-09 22:57:42 UTC
python-blivet-0.10-1.fc19,anaconda-19.17-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-blivet-0.10-1.fc19,anaconda-19.17-1.fc19

Comment 9 Fedora Update System 2013-04-10 15:18:48 UTC
Package python-blivet-0.10-1.fc19, anaconda-19.17-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-blivet-0.10-1.fc19 anaconda-19.17-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5323/python-blivet-0.10-1.fc19,anaconda-19.17-1.fc19
then log in and leave karma (feedback).

Comment 10 Adam Williamson 2013-04-11 19:58:12 UTC
Confirmed fixed in RC2, I can boot and initiate a text install with 512MB of RAM.

Comment 11 Adam Williamson 2013-04-11 20:07:08 UTC
I can also complete and boot a minimal text install with 512MB RAM, FWIW.

Comment 12 Adam Williamson 2013-04-30 18:45:07 UTC
We're well past 19.17 in stable now (19.22 is stable), so let's close this.


Note You need to log in before you can comment on or make changes to this bug.