Bug 947285 - grub finds no bootable image after save image to disk from Fedora-19 i686 live iso
Summary: grub finds no bootable image after save image to disk from Fedora-19 i686 liv...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: i686
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-02 03:58 UTC by John Ellson
Modified: 2014-06-30 13:22 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-30 13:22:54 UTC
Type: Bug


Attachments (Terms of Use)
/mnt/sysimage/var/log/anaconda/anaconda.log (10.25 KB, text/x-log)
2013-04-03 13:20 UTC, John Ellson
no flags Details
/mnt/sysimage/var/log/anaconda/anaconda.program.log (27.61 KB, text/x-log)
2013-04-03 13:21 UTC, John Ellson
no flags Details
/mnt/sysimage/etc/default/grub - 20130403.16-1 just before reboot into installed image (377 bytes, text/plain)
2013-04-04 19:15 UTC, John Ellson
no flags Details
/mnt/sysimage/var/log/anaconda/anaconda.log - 20130403.16-1 just before reboot into installed image (10.31 KB, text/plain)
2013-04-04 19:17 UTC, John Ellson
no flags Details
/mnt/sysimage/var/log/anaconda/anaconda.program.log - 20130403.16-1 just before reboot into installed image (27.50 KB, text/plain)
2013-04-04 19:18 UTC, John Ellson
no flags Details
tar of /mnt/sysimage/etc/grub.d - 20130403.16-1 just before reboot into installed image (70.00 KB, application/octet-stream)
2013-04-04 19:24 UTC, John Ellson
no flags Details

Description John Ellson 2013-04-02 03:58:03 UTC
Description of problem:
grub finds no bootable image after save image to disk from Fedora-19 i686 live iso

Attempting to boot results in a "grub>" prompt and 100% cpu load shown on virt-manager.

Propose FC18 blocker!

Version-Release number of selected component (if applicable):
Fedora-19-Alpha-TC3-i686-Live-Desktop.iso
Fedora-19-Nightly-20130401.13-i686-Live-xfce.iso


How reproducible:
100%

Steps to Reproduce:
1. install live image on virtual machine
2. save to hard drive
3. reboot
  
Actual results:
Reboot fails

Expected results:
Boot into installed Fedora-19 

Additional info:
Fedora-19-Nightly-20130329.11-x86_64-Live-xfce.iso
does *not* have the same issue.  I have been able to install Fedora-19 x86_64.

Comment 1 John Ellson 2013-04-02 03:59:40 UTC
That should read "Fedora-19 blocker"

Comment 2 Chris Lumens 2013-04-02 18:34:13 UTC
Please attach /var/log/anaconda/anaconda.log and /var/log/anaconda/program.log from your installed system to this bug report.

Comment 3 John Ellson 2013-04-03 03:55:27 UTC
Sorry, I don't know how to do that since the system is unbootable.

Can I mount the img from another virtual machine?  How?

Comment 4 John Ellson 2013-04-03 13:20:07 UTC
Created attachment 731147 [details]
/mnt/sysimage/var/log/anaconda/anaconda.log

 from just before reboot from live image

Comment 5 John Ellson 2013-04-03 13:21:57 UTC
Created attachment 731148 [details]
/mnt/sysimage/var/log/anaconda/anaconda.program.log

from just before reboot from live image

Comment 6 Chris Lumens 2013-04-04 17:34:02 UTC
00:26:51,125 INFO program: Generating grub.cfg ...
00:26:51,130 INFO program: Found theme: /boot/grub2/themes/system/theme.txt
00:26:51,130 INFO program: Found linux image: /boot/vmlinuz-3.9.0-0.rc4.git0.1.fc19.i686
00:26:51,131 INFO program: Found initrd image: /boot/initramfs-3.9.0-0.rc4.git0.1.fc19.i686.img
00:26:51,132 INFO program: Found linux image: /boot/vmlinuz-0-rescue-38ce06a405934ff891289d37cbacaa17
00:26:51,132 INFO program: Found initrd image: /boot/initramfs-0-rescue-38ce06a405934ff891289d37cbacaa17.img
00:26:51,133 INFO program: error: syntax error.
00:26:51,134 INFO program: error: Incorrect command.
00:26:51,134 INFO program: error: syntax error.
00:26:51,134 INFO program: Syntax error at line 152
00:26:51,134 INFO program: Syntax errors are detected in generated GRUB config file.
00:26:51,136 INFO program: Ensure that there are no errors in /etc/default/grub
00:26:51,136 INFO program: and /etc/grub.d/* files or please file a bug report with
00:26:51,136 INFO program: /boot/grub2/grub.cfg.new file attached.done

Could you also grab /etc/default/grub from this system and attach it as well?  THanks.

Comment 7 John Ellson 2013-04-04 19:13:21 UTC
Trying:

   Fedora-19-Nightly-20130403.16-i686-Live-xfce-20130403.16-1.iso

same problem.

There are files in /etc/grub.d/*   Do you need those too?

Comment 8 Chris Lumens 2013-04-04 19:14:47 UTC
Can't hurt to have them.

Comment 9 John Ellson 2013-04-04 19:15:38 UTC
Created attachment 731697 [details]
/mnt/sysimage/etc/default/grub  - 20130403.16-1 just before reboot into installed image

Comment 10 John Ellson 2013-04-04 19:17:07 UTC
Created attachment 731698 [details]
/mnt/sysimage/var/log/anaconda/anaconda.log - 20130403.16-1 just before reboot into installed image

Comment 11 John Ellson 2013-04-04 19:18:07 UTC
Created attachment 731699 [details]
/mnt/sysimage/var/log/anaconda/anaconda.program.log - 20130403.16-1 just before reboot into installed image

Comment 12 John Ellson 2013-04-04 19:24:09 UTC
Created attachment 731700 [details]
tar of /mnt/sysimage/etc/grub.d  - 20130403.16-1 just before reboot into installed image

Is a tar file OK?

Comment 13 John Ellson 2013-04-10 15:42:56 UTC
Still no go:

Fedora-19-Nightly-20130406.12-i686-Live-xfce-20130406.12-1.iso

Comment 14 John Ellson 2013-04-15 16:48:36 UTC
Still no go:

Fedora-19-Nightly-20130412.13-i686-Live-xfce-20130412.13-1.iso


Is no one else seeing this?   Seems very quiet for such a major bug!   Does it only affect KVM installs?

Comment 15 John Ellson 2013-04-22 19:13:44 UTC
Still no go:

Fedora-19-Nightly-20130419.11-i686-Live-xfce-20130419.11-1.iso

Comment 16 John Ellson 2013-04-23 20:27:35 UTC
Still no go with:

    Fedora-Live-XFCE-i686-19-Alpha-1.iso


But OK with minimal install from:

    Fedora-19-Alpha-i386-DVD.iso

Comment 17 Scott Dowdle 2013-04-24 21:29:36 UTC
Was that the tboot issue?  https://bugzilla.redhat.com/show_bug.cgi?id=955750

Comment 18 John Ellson 2013-04-25 15:09:16 UTC
Possibly. From comparing the Description in Bug#95570 with Comment#6 here it seems likely, although I don't quite understand how it got to a "tboot issue" ?

For me also the problem only affects 32 bit systems.

Does the "tboot issue" explain why it affects Live images, but not the DVD image?

Comment 19 John Ellson 2013-04-25 15:25:05 UTC
Possibly related?
    https://bugzilla.redhat.com/show_bug.cgi?id=912791

Comment 20 Cybertimber2011 2013-05-01 16:45:10 UTC
I hit this too on install with the Live iso (Fedora-Live-Desktop-i686-19-Alpha-1.iso) in VirtualBox 4.2.12. Haven't tried any nightlies (would have to download one), and will shortly try a physical system.

Proposing Release blocker per criteria:
" Expected installed system boot behavior
A system installed with a graphical package set must boot to the 'firstboot' utility on the first boot after installation. The firstboot utility must be able to create a working user account. "

Comment 21 Cybertimber2011 2013-05-04 18:04:23 UTC
Just tried Fedora-Live-Desktop-i686-19-Alpha-1.iso on a Dell Optiplex GX620 (Pentium D w/ 4GB RAM I think), and after install it booted to a grub prompt.
Installed using a USB stick created by using DD.

Fedora-Live-Desktop-i686-19-Beta-TC3-1.iso created by using LiveUSB creator 3.11.8 however worked on Dell Gx620. After install it showed the grub boot menu and booted successfully with a root password and user configured.

Might be worth trying John to see if you see the same.

Comment 22 Adam Williamson 2013-05-06 16:18:28 UTC
Discussed at 2013-05-06 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-06/f19beta-blocker-review-3.2013-05-06-16.02.log.txt . It looks like all the failure reports here are with Alpha images; John, can you please test with Beta TC3 or later and see if you are still having trouble? Cybertimer, if you're worried about the dd case, can you re-test that with a Beta TC3 or later image?

We will re-evaluate this at the next meeting; if we don't get any feedback on the situation with Beta, the bug is likely to be rejected as a blocker and/or closed. Thanks!

Comment 23 Cybertimber2011 2013-05-07 00:06:39 UTC
Sorry my comments caused some confusion here and in the blocker meeting. I don't think dd is related here as even in a virtual machine (VirtualBox) installing Fedora-Live-Desktop-i686-19-Alpha-1.iso it booted to the grub prompt and that was directly from the .iso.

Comment 24 Cybertimber2011 2013-05-07 03:17:49 UTC
I'm in the process of retesting on physical hardware. So far:
Fedora-Live-Desktop-i686-19-Alpha-1.iso using dd: Booted to grub.
Fedora-Live-Desktop-i686-19-Alpha-1.iso using live-to-usb: Booted to grub.
Fedora-Live-Desktop-i686-19-Beta-TC3-1 using dd: In progress
Fedora-Live-Desktop-i686-19-Beta-TC3-1 using live-to-usb: In Progress.


Are there any relevant logs I can grab before reboot that shows the grub install log? Even though it's working in Beta TC3-1, I'm not sure if it's wanted in case the problem returns.

Comment 25 Cybertimber2011 2013-05-07 13:51:27 UTC
Fedora-Live-Desktop-i686-19-Beta-TC3-1 using dd: Booted to Gnome desktop.
Fedora-Live-Desktop-i686-19-Beta-TC3-1 using live-to-usb: Booted to Gnome desktop.

I'd say reject the blocker since it seems fixed in TC3-1 and only affected the alpha.

Comment 26 Adam Williamson 2013-05-07 22:39:55 UTC
Thanks, Cyber. John, are you still experiencing problems with Beta TC3?

Comment 27 Adam Williamson 2013-05-08 16:50:15 UTC
Discussed at 2013-05-08 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-08/f19beta-blocker-review-4.2013-05-08-16.00.log.txt . Cybertimber no longer has an issue, and other validation testing of Beta TCs hasn't resulted in anyone else reproducing this issue so far as we know. We're not entirely sure what was going on in John's case, but for now, we decided to reject this as a blocker.

John, if you're still having trouble with current images, please update the bug with details and re-propose as a blocker if appropriate. Thanks!

Comment 28 John Ellson 2014-06-30 13:22:54 UTC
Ignore me - just trying to suppress the "needinfo" spam from this stale bug.


Note You need to log in before you can comment on or make changes to this bug.