Bug 947297 - libusbx-devel depends on libusbx-devel-doc, although there is no explicit dependency
Summary: libusbx-devel depends on libusbx-devel-doc, although there is no explicit dep...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libusbx
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-02 05:19 UTC by Alex G.
Modified: 2013-04-20 19:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-02 17:41:32 UTC
Type: Bug


Attachments (Terms of Use)

Description Alex G. 2013-04-02 05:19:12 UTC
Description of problem:
libusbx-devel depends on libusbx-devel-doc, but there is absolutely nothing that I could find that requires the -doc package to be installed with the -devel package.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. yum install libusbx-devel
2. yum remove libusbx-devel-doc
  
Actual results:
yum wants to remove libusbx-devel due to the dependency.

Expected results:
libusbx-devel-doc is removed without affecting other packages.

Additional info:
Some users prefer to read documentation online, or from other sources, and should not be forced to have -doc subpackages installed alongside -devel.
I uncovered this during a system cleanup where I wanted removed unused -doc:

# rpm -qa | grep "\-doc" |grep -v "stuff_to_keep" | xargs yum remove

Comment 1 Hans de Goede 2013-04-02 17:41:32 UTC
Hi,

Thanks for the bug report. This was originally done, because the devel-docs used to be part of the -devel package and then moved to their own package so they could be noarch, to avoid multilib problems.

When this split was done, the Requires were added to make sure that people moving from the non split package to the split one did not all of a sudden loose the devel-docs.

Since all support Fedora versions now have the split version, these Requires to ensure a proper upgrade path are no longer needed and can be dropped.

I'll push builds fixing this to F-19 and rawhide, I don't believe this warrants an update for F-18.

Regards,

Hans

Comment 2 Fedora Update System 2013-04-03 10:42:03 UTC
libusbx-1.0.14-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libusbx-1.0.14-3.fc19

Comment 3 Fedora Update System 2013-04-20 19:32:00 UTC
libusbx-1.0.14-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.