Bug 947813 - libssh2.pc is polluted with -Wl,-z,relro
Summary: libssh2.pc is polluted with -Wl,-z,relro
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libssh2
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-03 10:41 UTC by Daniel Berrangé
Modified: 2013-08-19 09:02 UTC (History)
3 users (show)

Fixed In Version: libssh2-1.4.3-2.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-19 09:02:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Daniel Berrangé 2013-04-03 10:41:53 UTC
Description of problem:
The libssh2.pc file contains

  Libs: -L${libdir} -lssh2 -Wl,-z,relro  

The inclusion of '-Wl,-z,relro' is bad because while it is valid for libssh2 itself to be compiled with this option, it should not be forced onto apps using libssh2. They must be allowed to opt-in to that as they wish


Version-Release number of selected component (if applicable):
libssh2-1.4.3-1.fc18.x86_64

How reproducible:
Always

Steps to Reproduce:
1.$ pkg-config --libs libssh2
2.
3.
  
Actual results:
-Wl,-z,relro -lssh2  



Expected results:
-lssh2  



Additional info:

Comment 1 Fedora Update System 2013-04-03 12:14:08 UTC
libssh2-1.4.3-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libssh2-1.4.3-4.fc19

Comment 2 Fedora Update System 2013-04-03 12:14:42 UTC
libssh2-1.4.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libssh2-1.4.3-2.fc18

Comment 3 Fedora Update System 2013-04-18 02:25:54 UTC
libssh2-1.4.3-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2013-04-20 20:04:20 UTC
libssh2-1.4.3-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.