Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 947832 - Empty translation page when pushing next
Empty translation page when pushing next
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Retired
Component: Usability (Show other bugs)
2.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.3
Assigned To: Alex Eng
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-03 07:51 EDT by Laszlo Hornyak
Modified: 2013-11-26 22:36 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.3-SNAPSHOT (20130419-0036)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 22:23:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laszlo Hornyak 2013-04-03 07:51:09 EDT
Description of problem:
The paging is not behaving quite correctly with the "untranslated" and "need review" filters.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Find a translation resource with entries enough for 2 pages
2. turn on "untranslated" and "need review"
3. translate all the entries on the first page
4. click on the next page
  
Actual results:
empty page appears

Expected results:
A page with untranslated entries should appear

Additional info:

Version 2.2.2 at https://translate.zanata.org/zanata/
reproduced on the ovirt project hu translation
Comment 1 Alex Eng 2013-04-03 18:15:06 EDT
Laszlo, 

This might related to the https://bugzilla.redhat.com/show_bug.cgi?id=947871
which caused by data index problem. 

I've fixed the problem by reindex the data. Can you please verify if the problem is still there?
Comment 2 Ding-Yi Chen 2013-04-09 01:13:56 EDT
I cannot reproduce this bug.
Laszlo, would you mind trying this again to see whether this problem cause by index corruption?
Comment 3 Laszlo Hornyak 2013-04-16 11:20:22 EDT
(In reply to comment #2)
> I cannot reproduce this bug.
> Laszlo, would you mind trying this again to see whether this problem cause
> by index corruption?

Hi,

It appears it is still behaving like that. I tested with a resource that was only enough for two pages and the problem re-occured. Probably the easiest way to do this is to got to any resource, go to the last page and then to the previous page, translate everything there, and when you are done click next, and you will get the empty page.
Comment 4 Alex Eng 2013-04-16 18:20:18 EDT
Hi Laszlo, 

Can you please provide us with the URL to that particular project that you're are having problem with:

e.g http://translate.zanata.org/webtrans/translate?project=authconfig&iteration=6.1.12-8&localeId=en-US&locale=en#view:doc;doc:authconfig
Comment 5 Alex Eng 2013-04-16 18:24:08 EDT
And also, did you use the back button in browser or the "paging" arrow at the bottom in editor to navigate between pages? If you can, please provide us with the steps to reproduce the problem.
Comment 7 Laszlo Hornyak 2013-04-17 03:07:40 EDT
Oh, this may be a pebkac, but I am clicking on the ">" on the bottom of the page, while I probably should click on the upper right ">" link to get the next page of untranslated strings.

Maybe it would make sense to place the same functionality on the bottom ">" link as well. When you reach the bottom of the page in a translation, it is closer to the focus of the attention.
Comment 9 Ding-Yi Chen 2013-04-18 20:53:23 EDT
The steps to reproduce this bug was:
1. Visit a long, mostly untranslated document.
2. Check the NeedReview and Untranslated filters.
3. Switch to second last page
4. Translate all the document of that page.
5. Switch to next page.

Actual:
Since there is nothing in next after applying fliter, the page is empty.

Expected:
Switch page to the last avail page.
Comment 10 Ding-Yi Chen 2013-04-18 20:53:57 EDT
VERIFIED with Zanata version 2.3-SNAPSHOT (20130419-0036).
Comment 12 Sean Flanigan 2013-11-26 22:13:56 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 13 Sean Flanigan 2013-11-26 22:15:49 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 14 Sean Flanigan 2013-11-26 22:19:25 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 15 Sean Flanigan 2013-11-26 22:23:45 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 16 Sean Flanigan 2013-11-26 22:34:11 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.
Comment 17 Sean Flanigan 2013-11-26 22:36:21 EST
Closing VERIFIED bugs for Zanata versions <= 3.1.

Note You need to log in before you can comment on or make changes to this bug.