Bug 948210 - vdsm: [scale] vdsm restarts after getting "No free file handlers in pool" when deleting (+ wipe after delete) ~150 vms
Summary: vdsm: [scale] vdsm restarts after getting "No free file handlers in pool" wh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.2.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ovirt-3.6.5
: 3.6.3
Assignee: Nir Soffer
QA Contact: guy chen
URL:
Whiteboard:
Depends On: 920532 922517 948214
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-04 10:12 UTC by Barak
Modified: 2016-04-20 16:25 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 922517
Environment:
Last Closed: 2016-04-20 16:25:08 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0660 0 normal SHIPPED_LIVE vdsm 3.6.5 bug fix and enhancement update 2016-04-20 20:23:46 UTC

Comment 10 Allon Mureinik 2015-06-18 13:35:59 UTC
Should be a non-issue in 3.6.0.
Moving to the scale team to verify.

Comment 12 guy chen 2016-04-14 07:31:57 UTC
Verified

Was tested on VDSM 4.17.25, VDSM stayed up and did not restart during the procedure. 

Steps that where Reproduced:
1. created iscsi pools with 3 domains 100G each
2. created a wipe=true template (1GB disk)
3. created 3 pools from the template with 50 vm's on each pool
4. detach and remove the vm from each pool without waiting for previous pool to be deleted.

Comment 14 errata-xmlrpc 2016-04-20 16:25:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0660.html


Note You need to log in before you can comment on or make changes to this bug.