Bug 9485 - update exits w/o warning
update exits w/o warning
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: bdflush (Show other bugs)
6.1
All Linux
medium Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-16 12:45 EST by Jerrad Pierce
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-18 10:38:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerrad Pierce 2000-02-16 12:45:45 EST
update (bdflush) will not run persistently as a daemon on a 6.1 box/
I have 5.1 and 6.0 boxes and it's running fine.

This is bad, the buffer on my machine grew to almost all
physical memory (249 of 256 M), and caused massive failures:
Out of memory errors in demesg and zombies. After doing many
unpleasant things I was able to prevent it going over 80 M,
but this still caused problems. As a temporary fix I'm using
200% CPU (to go over the 1.0 load avg I'm told is necessary
to force flushing), and this is working for now... but it's
most uncool.

bdflush needs to be fixed.

Ideally also, it would be nice that when an Out of memory message occurs,
the disk buffer is flushed.. perhaps even:
before a process spawns, is there at least as much free memory as the
parent uses? if not flush buffer...
Comment 1 giulioo 2000-03-05 12:07:59 EST
Is update/bdflush still needed after kernel 2.2.8?

=== http://www.kernelnotes.org/kernel/v2.2/0-9.html
...
Linux 2.2.8 patch - patch-2.2.8.gz (11-May-99)
    [Patch Browser]

Notes: Due to the changes in this kernel's buffer code, you may want to disable
the update (bdflush) daemon in your init scripts.
...
===

Note You need to log in before you can comment on or make changes to this bug.