Bug 948636 - Request for including Windows Dynamic Disk support in stock Fedora kernel
Summary: Request for including Windows Dynamic Disk support in stock Fedora kernel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 18
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-04 21:42 UTC by Lenry
Modified: 2013-04-19 05:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-04-15 23:51:37 UTC


Attachments (Terms of Use)

Description Lenry 2013-04-04 21:42:40 UTC
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build Identifier: 

I would like to request to defaultly enable Windows Dynamic disk support in the stock Fedora kernel, as I have a disk with dynamic partitions on it, one of them being /home (don't ask), and every time there is an update for the kernel, I have to recompile it because of that one tick in the kernelconfig.

Reproducible: Always

Steps to Reproduce:
1. have a disk with dynamic partiton
2. try to mount them
Actual Results:  
Fedora will be unable to recognize the partitions on that disk, including /home, rendering the system unbootable with the new kernel.

Comment 1 Josh Boyer 2013-04-12 15:50:43 UTC
OK.  We'll enable this.  A couple of notes:

1) It doesn't support GPT labeled dynamic partitions (possible starting with Vista I believe)

2) If for some reason it starts causing problems, it's likely to get turned back off rather quickly.

3) We aren't going to be in a position to explicitly test this, so if it breaks in the future we probably aren't going to notice.

Comment 2 Fedora Update System 2013-04-12 21:23:06 UTC
kernel-3.8.7-201.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.8.7-201.fc18

Comment 3 Fedora Update System 2013-04-14 00:24:52 UTC
Package kernel-3.8.7-201.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.8.7-201.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5617/kernel-3.8.7-201.fc18
then log in and leave karma (feedback).

Comment 4 Lenry 2013-04-15 18:23:50 UTC
I will try it at once, thank you!

Comment 5 Fedora Update System 2013-04-15 21:57:22 UTC
kernel-3.9.0-0.rc6.git2.3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-5224/kernel-3.9.0-0.rc6.git2.3.fc19

Comment 6 Fedora Update System 2013-04-15 23:51:38 UTC
kernel-3.8.7-201.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2013-04-19 05:47:53 UTC
kernel-3.9.0-0.rc6.git2.3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.