Bug 948730 - Mount command line is logged at inappropriate log level
Summary: Mount command line is logged at inappropriate log level
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: resource-agents
Version: 6.4
Hardware: All
OS: Linux
medium
low
Target Milestone: rc
: ---
Assignee: David Vossel
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 835616 960054
TreeView+ depends on / blocked
 
Reported: 2013-04-05 08:56 UTC by J.H.M. Dassen (Ray)
Modified: 2018-12-03 18:36 UTC (History)
9 users (show)

Fixed In Version: resource-agents-3.9.2-25.el6
Doc Type: Bug Fix
Doc Text:
Cause: Mount command outputs as error msg. Consequence: Clutters logs, isn't an error. Fix: Set log level to debug. Result:
Clone Of:
Environment:
Last Closed: 2013-11-21 05:19:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 426173 0 None None None Never
Red Hat Product Errata RHBA-2013:1541 0 normal SHIPPED_LIVE resource-agents bug fix and enhancement update 2013-11-20 21:40:47 UTC

Description J.H.M. Dassen (Ray) 2013-04-05 08:56:32 UTC
Description of problem:
Please backport <https://github.com/ClusterLabs/resource-agents/pull/220>.

Version-Release number of selected component (if applicable):
resource-agents-3.9.2-12.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Set up a cluster with an "fs" resource.
2. Start cluster or induce a failover of the "fs" resource.
  
Actual results:
Mount command lines (e.g. "[fs] mount -t ext4  /dev/mapper/VGmysqldb1-LVmysqldb /opt/MYSQLDB1") are logged at LOG_ERR syslog priority.

Expected results:
"mount" command lines are logged at LOG_DEBUG priority. They do not indicate error conditions, so LOG_ERR is unwarranted.

Comment 1 David Vossel 2013-05-29 19:45:47 UTC
Upstream patch related to this issue.

https://github.com/ClusterLabs/resource-agents/commit/8dc0e72bcec6f84fc23aa09dc924770d332aa823

Comment 6 michal novacek 2013-09-17 15:39:46 UTC
I have verified that the patch is applyied:


# rpm -q resource-agents
resource-agents-3.9.2-33.el6.x86_64

# rpm -qf /usr/share/cluster/utils/fs-lib.sh
resource-agents-3.9.2-33.el6.x86_64

# grep -A 5 'cf_log info "mounting' /usr/share/cluster/utils/fs-lib.sh
        ocf_log info "mounting $dev on $mp"
        ocf_log debug "mount $fstype_option $mount_options $dev $mp"
        mount $fstype_option $mount_options "$dev" "$mp"
        ret_val=$?
        if [ $ret_val -ne 0 ]; then
                ocf_log err

Comment 8 errata-xmlrpc 2013-11-21 05:19:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1541.html


Note You need to log in before you can comment on or make changes to this bug.