Bug 948746 - [User Portal] 'Pass Ctrl-Alt-Del to virtual machines' checkbox visible changes for clients >= Win7
Summary: [User Portal] 'Pass Ctrl-Alt-Del to virtual machines' checkbox visible change...
Keywords:
Status: CLOSED DUPLICATE of bug 1029441
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.4.0
Assignee: Frantisek Kobzik
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
Depends On: 1029441 1042782
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-05 09:58 UTC by Jiri Belka
Modified: 2015-09-22 13:09 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-06 13:41:54 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Jiri Belka 2013-04-05 09:58:57 UTC
Description of problem:
This does not seem to affect real functionality of 'Pass Ctrl-Alt-Del to virtual machine' feature. But anyway...

When you check VM's console options for SPICE in User Portal _right_ after logging in (you have _not_ opened VM's SPICE console yet!), you would see that 'Pass Ctrl-Alt-Del to virtual machine' checkbox is grey (OK) and checkbox checked/enabled/selected (NOT OK for clients >= Windows 7). See about funcionality BZ918650.

Then after opening and closing console for such VM, when you check VM's console options for SPICE again, you would see that 'Pass Ctrl-Alt-Del to virtual machine' checkbox is grey (OK) and checkbox is unchecked/disabled/not-selected (OK).

There's UI inconsistency between funcionality and what is rendered in web ui.

Version-Release number of selected component (if applicable):
sf13
clients: w2k8r2, w7 64bit tested

How reproducible:
100%

Steps to Reproduce:
1. open UP
2. check VM's SPICE console options for checkbox status of 'Pass Ctrl-Alt-Del to virtual machine'
3. open VM's console with double clicking on its "icon"
4. check VM's SPICE console options for checkbox status of 'Pass Ctrl-Alt-Del to virtual machine'
  
Actual results:
inconsitency with funcionality. for clients >= Win 7, the checkbox is checked in spice console options prior opening VM's console

Expected results:
for clients >= Win 7, the checkbox should be never checked in spice console

Additional info:

Comment 1 Michal Skrivanek 2013-09-05 12:45:29 UTC
SPICE will provide a different(and configurable)s shortcut for CAD, and the option here can be removed completely then

Comment 2 Frantisek Kobzik 2013-11-14 12:48:23 UTC
When 1029441 is solved, this bug won't bother us anymore.

Comment 3 Frantisek Kobzik 2014-01-06 13:41:54 UTC
The 'Pass c-a-d to vm' option is now removed from the engine (in favor of bz#1029441 (remapping ctrl-alt-del keystroke to ctrl-alt-end)).

Comment 4 Frantisek Kobzik 2014-01-06 14:02:16 UTC
(correcting cause of closure to 'duplicate')

*** This bug has been marked as a duplicate of bug 1029441 ***


Note You need to log in before you can comment on or make changes to this bug.