Bug 948788 - do not put metalink URL in mirrorlist= field in the repo files
do not put metalink URL in mirrorlist= field in the repo files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-05 08:48 EDT by Ales Kozumplik
Modified: 2014-09-30 19:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 12:32:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Kozumplik 2013-04-05 08:48:10 EDT
Lines like this in the repo:

mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch

only work because yum searches the URL for the 'metalink?' string. This behaviour makes processing the config files and setting up repositories quite complex. Let's start making this right by fixing the repo files, e.g. to something like:

metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-$releasever&arch=$basearch
Comment 1 Dennis Gilmore 2013-07-08 12:32:16 EDT
Just committed a build changing mirrorlist to metalink in rawhide
Comment 2 Ales Kozumplik 2013-09-16 06:55:53 EDT
Commit f19fc52 addresses this change in DNF (i.e. simplifies the repo configuration code).
Comment 3 Tomas Mlcoch 2013-09-17 08:28:38 EDT
Librepo, since 636e7ef, consider LRO_MIRRORLIST (the option that accepts mirrorlist url as well as metalink url) as s deprecated option and brings LRO_MIRRORLISTURL and LRO_METALINKURL instead.

Note You need to log in before you can comment on or make changes to this bug.