This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 9491 - loop device not freed after umount
loop device not freed after umount
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-16 14:57 EST by Vlado Potisk
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-05 10:28:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vlado Potisk 2000-02-16 14:57:23 EST
I use a file as a filesystem volume using the loop device,
the fstab entry looks like this:
	<myfile> <mountpoint> ext2 loop,user,noauto 0 0

I mount/umount this volume frequently as an ordinary user.
I noticed that after umount, the corresponding device /dev/loop0,
loop1, loop2, etc. gets not freed; after several umounts no loop
devices are left available and mount command fails. To correct it
I had to run losetup -d.

When root umounts the volume, everything looks fine.
The kernel is ver 2.2.11.
Comment 1 Bernhard Rosenkraenzer 2000-08-09 11:17:26 EDT
Looks like a kernel problem, probably fixed by now...
Comment 2 Ben LaHaise 2000-10-04 18:04:16 EDT
Does this still happen in RH7?
Comment 3 Vlado Potisk 2000-10-05 10:28:19 EDT
Don't know and cannot check version 7.0, but
6.2 with kernel 2.2.16 appears to have this bug
corrected.


Note You need to log in before you can comment on or make changes to this bug.